Support » Plugin: Wordfence Security - Firewall & Malware Scan » Wordfence Web Application Firewall Host Europe shared hosting

  • Resolved YogieAnamCara

    (@yogieanamcara)


    Hi,

    as far as I know I do not have access to the php.ini file as I use a shared hosting package at Host Europe. However I tried to run the WAF setup as Wordfence detected the web server settings. I get to the point where I download the .htaccess file and after clicking Continue I’m steadily redirected to the first page of the setup procedure.

    What shall I do?

    Cheers
    JK

    https://wordpress.org/plugins/wordfence/

    [Moderator Note: No bumping, thank you.]

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have three shared host providers in Europe with two the setup procedure worked.
    With one I had the same problem as described, after describing my problem to the shared host provider they checked the wordfence documentation and provided the solution.

    Check in your .htaccess file, the code wordfence added in this file delete everything accept the part starting with

    php_value auto_prepend_file that solved the problem.

    Hello Wimgbax,

    I do not know exactly what you mean. What needs to be added or deleted by Wordfence?

    It looks like I have a new block like:

    #WFIPBLOCKS – Do not remove this line. Disable Web Caching in Wordfence to remove this data.
    Order Deny,Allow
    Deny from <ipAddressHere>
    #Do not remove this line. Disable Web Caching in Wordfence to remove this data – WFIPBLOCKS
    #WFCACHECODE – Do not remove this line. Disable Web Caching in Wordfence to remove this data.

    on top of my other lines…

    The string “php_value auto_prepend_file” is not in my .htaccess at all?

    But still I have a notice that the Wordfence Web Application Firewall needs to be configured and I need to add the line to the php.ini (which I can’t).

    I simply added

    # WordFence Firewall
    php_value auto_prepend_file <path and filename from the WAF>

    to my .htaccess

    which fixed the problem

    Hello Joerg,
    sorry we were not able to get to your support request in time but I’m glad you were able to figure it out yourself.

    You should add this to the documentation! Is there a channel where I get a faster reply as I am a paid user?

    Hello again,
    yes we have a premium support forum for premium members only. It offers a much higher level of support.

    Where can I find it?

    Hello Joerg,
    you can find links to signup for premium membership on the the Wordfence plugin pages.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Wordfence Web Application Firewall Host Europe shared hosting’ is closed to new replies.