Support » Plugin: Wordfence Security - Firewall & Malware Scan » Wordfence – Warning on PHP 7.2

  • Resolved 77well88done99

    (@77well88done99)


    Hello,
    After the latest upgrade from PHP 7.1 to 7.2, I have got PHP error_log file on cPanel,

    Warning: get_class() expects parameter 1 to be object, null given in /home/…/public_html/wp-content/plugins/wordfence/lib/wordfenceClass.php on line 2293

    However there is no problem/error on my site with that warning, so is it just false-positive warning or can this be fixed?

    Thanks for your help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi,
    Could you please confirm that you are running the latest version of Wordfence plugin which is “7.1.1” by now?

    Thanks.

    Thread Starter 77well88done99

    (@77well88done99)

    Thanks for your reply, I have updated to the latest version of Wordfence 7.1.1 plugin, and still get the PHP warning with different line from wordfenceClass.php file.

    PHP Warning: get_class() expects parameter 1 to be object, null given in /home/…/public_html/wp-content/plugins/wordfence/lib/wordfenceClass.php on line 2333

    This is Link

    Thanks in advance.

    Hi @77well88done99
    Thanks for this information, I’ve logged this issue to our dev team (internal reference number: FB6882) it will be addressed in one of the next releases.

    Thanks.

    Thread Starter 77well88done99

    (@77well88done99)

    Ok @wfalaa, Thanks for the attention & information above. It’s really happy for having a great wordfence security plugin and good support!

    Regards.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Wordfence – Warning on PHP 7.2’ is closed to new replies.