Support » Plugin: Wordfence Security - Firewall & Malware Scan » Wordfence version 6.2.4 is here!

  • Plugin Author WFSupport

    (@wfsupport)


    Greetings all. We have a point release for Wordfence today, version 6.2.4. Please update as soon as you are able.

    • Improvement: Scan times for very large sites with huge numbers of files are greatly improved.
    • Improvement: Added a configurable time limit for scans to help reduce overall server load and identify configuration problems.
    • Improvement: Email-based logins are now covered by “Don’t let WordPress reveal valid users in login errors”.
    • Improvement: Extended rate limiting support to the login page.
    • Fix: Fixed a case where files in the site root with issues could have them added multiple times.
    • Fix: Improved IP detection in the WAF when using an IP detection method that can have multiple values.
    • Fix: Added a safety check for when the database fails to return its max_allowed_packet value.
    • Fix: Added safety checks for when the configuration table migration has failed.
    • Fix: Added a couple rare failed login error codes to brute force detection.
    • Fix: Fixed a sequencing problem when adding detection for bot/human that led to it being called on every request.
    • Fix: Suppressed errors if a file is removed between the start of a scan and later scan stages.
    • Fix: Addressed a problem where the scan exclusions list was not checked correctly in some situations.

    Thanks everyone for great comments and suggestions. Send any of those you might have to feedback@wordfence.com and someone will get back to you.
    Keep in mind, the feedback address is not a place to request support.
    Also, no support questions will be answered in this thread.
    Free support requests can be posted at https://wordpress.org/support/plugin/wordfence
    Our premium customers can open a ticket at http://support.wordfence.com

Viewing 1 replies (of 1 total)
  • mitchellk

    (@mitchellk)

    BROKE my entire web site …. need instructions to manually remove the plugin completely as I cannot even get into wp-admin.

    PHP message: PHP Fatal error: Unknown: Failed opening required ‘/var/www/mysite/wordfence-waf.php’ (include_path=’.:/usr/share/php’) in Unknown on line 0″ while reading response header from upstream, client: 154.70.236.33

    Please urgently need instruction to completely remove this manually as you have broken a very important web site now from the auto upgrade this morning. I run 28 other sites on the server and they all updated but the update on this one site completely stopped the site working and now only 500 errors. PLEASE !!!!

Viewing 1 replies (of 1 total)
  • The topic ‘Wordfence version 6.2.4 is here!’ is closed to new replies.