Support » Plugin: Wordfence Security - Firewall & Malware Scan » Wordfence Server URL

  • Resolved Emanuel Borbon

    (@eborbon)


    Hi
    I have a problem doing a Scan in my site, when I do the scan, the plugin can’t connect to your servers, could help me with the URL to connect to your serves to put it in a Whitelist, it’s because the traffic of our server is very limited
    Thanks a lot

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support WFAdam

    (@wfadam)

    Hello @eborbon and thanks for reaching out to us!

    If you could do the following for me so I can see where the scan is having the error:

    • Go to the Tools > Diagnostics page
    • In the “Debugging Options” section check the circle “Enable debugging mode”
    • Click to “Save Changes”.
    • Start a new scan
    • Copy the last 20 lines from the Log (click the “Show Log” link) or so of the activity log and paste them in the post.

    Make sure you haven’t blocked Wordfence’s scanning server’s IP address range from accessing your site. Our servers are from 69.46.36.0 to 69.46.36.32. If your site is unable to connect to itself to start a scan, we get our scanning servers to connect to you to kick the scan off. If you’ve blocked our servers, your scans won’t start. The newest version of Wordfence has code that prevents you from blocking individual addresses in our range but you can still block our entire network, so make sure you haven’t done that. If you are unsure, check with your hosting provider and ask them if they are blocking outbound connections to our IP address range.

    https://www.wordfence.com/help/scan/troubleshooting/ is also a great reference for troubleshooting scans.

    Let me know if this helps!

    Thanks!

    Thread Starter Emanuel Borbon

    (@eborbon)

    Thank you very much
    The site has all external traffic blocked, so we will try to whitelist the IPs and try again.
    I checked the Diagnostics and an cURL 28 error is the problem, so maybe our server is the problem.
    In case that it doesn’t work I will send the debug to you.
    Thanks again

    Plugin Support WFAdam

    (@wfadam)

    Hello again @eborbon

    A cURL 28 error usually means the site is having issues connecting to our noc1 server.
    https://noc1.wordfence.com/

    Check Tools > Diagnostics > Connectivity, does everything say OK here?

    Let me know what you find!

    Thanks!

    Thread Starter Emanuel Borbon

    (@eborbon)

    Hello again @wfadam

    We put the URLs in a whitelist and it seems that it is already connecting, however it gives me this new error

    Wordfence API error: Your site did not send an API key when contacting the Wordfence servers.

    In Connectivity all looks fine
    And in Database tables all exits

    Plugin Support WFAdam

    (@wfadam)

    Hello again @eborbon

    Are you by chance hosted on a Windows-based server? This can be one of two things:
    1) Something is preventing your site from connecting to our scan servers, which you would have to contact your host to check on what might be causing that.
    2) You might have a corrupt data table. If your scans have worked in the past, lets try to reinstall Wordfence and repair the tables.

    You can backup your Wordfence settings via the Export option. Navigate to Wordfence > Tools > Import/Export Options and click Export. You can also take note of the current Whitelisted URLs you have in Wordfence > Firewall > All Firewall Options > Whitelisted URLs as these are NOT included in the Import/Export, and will be lost during the re-install.
    Here is what is exported: https://www.wordfence.com/help/tools/import-export/
    During the export, you will be given a long string of text. Keep this safe, you’ll need it in a few minutes.

    After that, enable the option to Delete Wordfence tables and data on deactivation in All Options > General Wordfence Options. You will want to remember to disable this after you reinstall Wordfence again.

    After you enable that option, you can deactivate Wordfence from the Plugins area of your site, then delete it. Next, from the plugins area, search for and re-install Wordfence like normal.

    It will be like setting Wordfence up for the first time. You will need to enter an email address, and then go into Tools > Import/Export Options and paste that string of text into the Import Wordfence Options field and click the button there.

    The firewall will be in Learning Mode by default for 7 days. I would recommend switching this to Enabled and Protected as soon as possible.

    Let me know if this helps!

    Thanks!

    Thread Starter Emanuel Borbon

    (@eborbon)

    I cannot export because the same error appears
    But I found the error, the installation did not complete
    I finished configuring the firewall and now it is working
    Thank you very much for the help and sorry for the inconvenience.

    Plugin Support WFAdam

    (@wfadam)

    Glad you could find a resolution for this @eborbon

    If you have any other issues or questions, please feel free to post a new topic and we would be happy to assist you!

    Thanks for your support!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Wordfence Server URL’ is closed to new replies.