Support » Plugin: File Manager » wordfence security plugin reporting issues with plugin

  • Resolved snioefkhjw

    (@snioefkhjw)


    A client’s site is running WordPress 4.9.5 and WP File Manager 2.1. A recent scan by the Wordfence security plugin warned that the following files within the WP File Manager plugin were modified and different than the files distributed with the plugin through WordPress.org.

    * Modified plugin file: wp-content/plugins/wp-file-manager/file_folder_manager.php
    * Modified plugin file: wp-content/plugins/wp-file-manager/lib/php/elFinder.class.php

    Why are these files being modified/changed from the files that are distributed through WordPress.org? Have proper release procedures been followed when releasing updates to the plugin?

    Please explain.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author mndpsingh287

    (@mndpsingh287)

    Hey @snioefkhjw,

    Please accept our apologies for confusion. We changed these files to make our plugin compatible to php7. We will raise plugin version to 2.2. We did that thing instantly for new users to get their feedback. We solved following support request.

    https://wordpress.org/support/topic/php-7-incompatibility-error/

    Thanks,
    Mandeep

    Hello Mandeep,

    I have run into the same issue with Wordfence. Looks like the current version of file_folder_manager.php is already 2.4.

    Am not throwing the error for /lib/php/elFinder.class.php.

    Will ignore errors until everything settles down.

    Regards,

    Rick

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.