Support » Plugin: Wordfence Security - Firewall & Malware Scan » WordFence Scan Stuck on 1 website

  • Resolved kenweill

    (@kenweill)


    I have two WP sites hosted as add-on, on the same hosting provider, on the same account.

    1 WP site with WordFence have no problem, scan don’t. Finished without a problem.
    2nd website with WordFence stuck at:
    Scanning file contents for infections and vulnerabilities
    Scanning files for URLs in Google’s Safe Browsing List

    Data for “Test your WordPress host’s available memory”:
    Wordfence Memory benchmarking utility version 6.2.6.
    This utility tests if your WordPress host respects the maximum memory configured
    in their php.ini file, or if they are using other methods to limit your access to memory.

    –Starting test–
    Current maximum memory configured in php.ini: 768M
    Current memory usage: 44.50M
    Setting max memory to 90M.
    Starting memory benchmark. Seeing an error after this line is not unusual. Read the error carefully
    to determine how much memory your host allows. We have requested 90 megabytes.
    Completing test after benchmarking up to 80.25 megabytes.
    –Test complete.–

    Congratulations, your web host allows you to use at least 80.25 megabytes of memory for each PHP process hosting your WordPress site.

    Here are the two server error logs on my hosting:
    [Tue Nov 22 19:42:09.454159 2016] [:warn] [pid 24768] [client 109.73.234.181:55614] Timeout waiting for output from CGI script /home/………./wp-admin/admin-ajax.php, referer: ………./wp-admin/admin-ajax.php?action=wordfence_doScan&isFork=0&cronKey=23dee8c8123419b448a5ff3
    [Tue Nov 22 19:41:39.424182 2016] [:warn] [pid 24768] [client 109.73.234.181:55614] Timeout waiting for output from CGI script /home/………./wp-admin/admin-ajax.php, referer: ………./wp-admin/admin-ajax.php?action=wordfence_doScan&isFork=0&cronKey=23dee8c8123419b448a5ff3

    I’m don’t think this is a server issue as it works on the other website, hosted on the same server, on the same account. Both (2) websites are installed as add-ons.

    • This topic was modified 3 years ago by kenweill.
Viewing 2 replies - 1 through 2 (of 2 total)
  • kenweill

    (@kenweill)

    Problem fixed by setting Maximum execution time for each scan stage to “12”.

    Tried 50, 30, 15 and it doesn’t work. Fixed it on “12”.

    Same problema here, was getting this at server logs:

    [Wed Feb 15 07:58:57.643784 2017] [:warn] [pid 3921] [client 184.154.233.95:37650] Timeout waiting for output from CGI script

    Solved with you configuration tip

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘WordFence Scan Stuck on 1 website’ is closed to new replies.