Support » Plugin: Wordfence Security - Firewall & Malware Scan » Wordfence preventing WP establishing “a secure connection to WordPress.org”

  • Resolved kosmicare

    (@kosmicare)


    I am getting the following error when adding or updating all plugins. The update process is very slow (over 60s) but the plugins do eventually install.

    > Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/user/public_html/wp/wp-includes/update.php on line 607

    I do not see the error when I disable Wordfence.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support wfpeter

    (@wfpeter)

    Hi @kosmicare, thanks for your query about this issue.

    It’s interesting that the plugins do install despite the delay, so you are not being blocked from WordPress.org entirely. As you did not include the URL of your website with the ticket, do you have an SSL certificate for your domain that is running WordPress & Wordfence?

    There is a chance there is an issue between your host and outbound connections, but I would like to see a diagnostic report. Could you please send one to wftest @ wordfence . com? You can find the link to do so at the top of the Wordfence Tools > Diagnostics page. Then click on “Send Report by Email”. Please add your forum username where indicated and respond here after you have sent it.

    Note: For the fastest response time, please make sure and add any information or questions directly to this topic and not the email address above unless asked.

    Thanks,

    Peter.

    Thread Starter kosmicare

    (@kosmicare)

    I disabled WF for a little while so that I could quickly install some new plugins.
    I found that the error still occurred on one occasion. Therefore I am no longer certain that the problem is caused by WF.

    I have contacted my hosting provider. I will contact you if the situation changes and I think that WF might be involved.
    Thanks for your help.

    Plugin Support wfpeter

    (@wfpeter)

    Hi @kosmicare,

    Thanks for the reply. We have seen outbound connection issues with hosts before so it does sound probable that they could resolve this for you. I will leave this topic open for the time being, just in case it needs picking back up.

    Let us know how you get on!

    Peter.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Wordfence preventing WP establishing “a secure connection to WordPress.org”’ is closed to new replies.