Support » Plugin: Wordfence Security » Wordfence plugin installation breaking rackspace cloud site!

  • Resolved gurusurfer

    (@gurusurfer)


    Hi,

    When trying to activate wordfence after a download to a rackspace cloud hosted wordpress site, the site is breaking on spot. I have contacted rackspace and the ticket response was that it is a plugin problem.

    Here is how the ticket was submitted:

    – website crashing when enabling wordfence wordpress plugin
    – while activating the plugin, the average load on both servers increases up to more than 100 (being cause by the multiple php-fpm processes)
    – the only error shown in the logs:
    PHP Fatal error: require(): Failed opening required ‘wfBrowscapCache.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /var/www/html/wp-co ntent/plugins/wordfence/lib/wfBrowscap.php on line 87
    – disabled all caching processes (varnishd, memcached) at customer’s request on master server “londonreal-web1-8gb”
    – the plugin is now disabled from the wordpress control panel; please investigate this issue and enable the wordfence plugin.

    Any help is appreciated, thanks.

    https://wordpress.org/plugins/wordfence/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author WFMattR

    (@wfmattr)

    Can you check if the file in the error message exists, and if it has the right permissions, so the web server user can read and write it? The full path to the file above was:
    /var/www/html/wp-content/plugins/wordfence/lib/wfBrowscap.php

    There might have been a problem while installing the plugin since that file should be there, so removing the Wordfence plugin and reinstalling it may fix it, especially if the file is missing, or damaged in some way. There may be something more to this problem, as that alone shouldn’t normally cause the php processes to hang.

    If you try reactivating the plugin and have the same problem, you can use FTP or SSH to rename the Wordfence folder (wp-content/plugins/wordfence/), and WordPress will disable it automatically.

    -Matt R

    Can you check if the file in the error message exists, and if it has the right permissions, so the web server user can read and write it? The full path to the file above was:
    /var/www/html/wp-content/plugins/wordfence/lib/wfBrowscap.php

    /wordfence/lib/wfBrowscap.php exists and I set the file permissions to 777 but still no luck.

    There might have been a problem while installing the plugin since that file should be there, so removing the Wordfence plugin and reinstalling it may fix it, especially if the file is missing, or damaged in some way.

    I did many times with no luck!

    If you try reactivating the plugin and have the same problem, you can use FTP or SSH to rename the Wordfence folder (wp-content/plugins/wordfence/), and WordPress will disable it automatically.

    Yes that is how I get back the site every time I reactivate!

    Any further help is much appreciated!

    Actually the required file is this:

    …/plugins/wordfence/lib/wfBrowscapCache.php

    Could also be a “not enough memory” problem. Would try to temporarily disable many/all other plugins and see if the error is still the same.

    Plugin Author WFMattR

    (@wfmattr)

    Ov3rfly: Thanks, you are correct on the file path.

    gurusurfer: Sorry for the mistake in the filename above — can you check if Ov3rfly’s suggestion helps?

    -Matt R

    I am on Rackspace and I run this plugin on 30+ sites without any problems. Are you using the cache portion? If so, just stop using that portion and use WP Super Cache. Rackspace even recommends WP Super Cache as their preferred Cache Plugin. At least the last time I looked that was the case.

    Good luck!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Wordfence plugin installation breaking rackspace cloud site!’ is closed to new replies.