Support » Plugin: Easy Theme and Plugin Upgrades » WordFence Plugin Conflict

  • omrudi

    (@omrudi)



    I discovered today that when the popular WordFence plugin is activated that it aborts the theme update. I get this error message: Fatal error: Maximum execution time of 30 seconds exceeded in /home/content/p3pnexwpnas09_data02/53/2782153/html/wp-content/plugins/wordfence/vendor/wordfence/wf-waf/src/lib/rules.php on line 727
    When the WordFence plugin is deactivated the theme update is successful.

Viewing 1 replies (of 1 total)
  • Plugin Author Chris Jean

    (@chrisjean)

    Based on the error message, I would assume that WordFence is trying to scan the uploaded zip file to detect any suspicious file contents. Since a theme zip is likely to be many megabytes in size, depending on how the scan functions, it could take quite a long time to try to scan the contents fully. It sounds like it would require more time than your server allows in order for the scan to complete.

    In short, there is nothing that Easy Theme and Plugin Upgrades can do in this situation. I think your options are:

    1) Get your server to allow more execution time.
    2) Disable the feature that performs the scanning before upgrading and re-enable it afterwards.
    3) Work with the WordFence devs to see if they can make the scan more efficient at handling zip files.

Viewing 1 replies (of 1 total)
  • The topic ‘WordFence Plugin Conflict’ is closed to new replies.