Support » Plugin: Wordfence Security - Firewall & Malware Scan » Wordfence not scanning

  • Resolved MarcGuay

    (@marcguay)


    WordPress 4.8.1
    Wordfence 6.3.16
    PHP 5.6.31
    Linux + Apache Web Server

    Hello. I’ve read through the docs here and tried the solutions to no avail: https://docs.wordfence.com/en/My_scans_don’t_finish._What_would_cause_that%3F. Specifically I have turned on debugging mode, tried “Start all scans remotely”, made sure memcached and opcache are not installed, verified that wp-admin is not being blocked (/wp-admin/admin-ajax.php is accessible and returns 0). Here is the content of the activity log:

    [Aug 17 14:52:07] Ajax request received to start scan.
    [Aug 17 14:52:07] Entering start scan routine
    [Aug 17 14:52:07] Got value from wf config maxExecutionTime: 12
    [Aug 17 14:52:07] getMaxExecutionTime() returning config value: 12
    [Aug 17 14:52:07] Starting cron via proxy at URL http://noc1.wordfence.com/scanp/xxx.com/wp-admin/admin-ajax.php?lang=en?action=wordfence_doScan&isFork=0&scanMode=full&cronKey=xxx
    [Aug 17 14:52:08] Scan process ended after forking.

    I also noticed that on the Tools->Diagnostic page in the “Connecting back to this site” there is the following error:

    wp_remote_post() test back to this server failed! Response was: 200 OK<br /> This additional info may help you diagnose the issue. The response headers we received were:<br /> date => Thu, 17 Aug 2017 14:54:09 GMT<br /> server => Apache<br /> x-robots-tag => noindex<br /> x-content-type-options => nosniff<br /> expires => Wed, 11 Jan 1984 05:00:00 GMT<br /> cache-control => no-cache, must-revalidate, max-age=0<br /> x-frame-options => SAMEORIGIN<br /> content-length => 1<br /> content-type => text/html; charset=UTF-8<br />

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi,
    It’s a little bit strange to have the “wp_remote_post() test” marked as failed while its “response was: 200 OK”! but definitely this could be the reason for this issue, please go to (Wordfence > Tools => Diagnostics) and click on “Send Report by Email” button at the top of the page, you can send the report to “alaa [at] wordfence [dot] com”, make sure to include your forum username, I will take a look at this report and let you know my findings.

    Thanks.

    Thank you, it is sent.

    Please try to switch to the default WordPress theme and check the “Connecting back to this site” test result, also try to disable your plugins “except Wordfence” -temporarily- and re-check both the test and the scan issue.

    Let me know how it goes,
    Thanks.

    Just switching to the parent theme fixes the issue so there is something in my child theme causing the problem. Any suggestions on what to look for?

    I’ve found the offending code. The site is quite old and is using qTranslate for multilanguage. In order for AJAX to work properly we’ve added a function which appends the language code to the URL in the admin_url filter.

    I see, thanks for sharing the reason behind this issue, after getting the “Connecting back to this site” test done successfully, can you please confirm that scan is working fine now?

    Thanks.

    Yes it works if the modifications are admin_url are removed. Since they are only needed on the frontend I’ve added a condition that prevents them from being modified on the admin pages using is_admin(). I suppose that Wordfence is checking the URL or perhaps modifying it itself, causing the problem. Thanks for your help!

    I am having this same problem with the 200 OK but no idea how to fix it – am not a PHP programmer, I’ve only done some basic things. My site has a child theme. Start scan causes it to start spinning for a couple seconds and then stops, nothing logged.

    Hi @mjducharme
    Please open a new support thread about your question as per forum rules. We will be glad to help you further to get this issue resolved.

    Thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Wordfence not scanning’ is closed to new replies.