Support » Plugin: Wordfence Security - Firewall & Malware Scan » Wordfence memory exhausted

  • Scan stalls. Don’t know why it asks for 355M of memory. Server mem is set to 512M

    [Sep 21 12:21:17] Analyzed 3200 files containing 40.66 MB of data so far
    [Sep 21 12:21:24] Fatal error: Allowed memory size of 335544320 bytes exhausted (tried to allocate 32 bytes) in /usr/www/users/febete/wp-content/plugins/wordfence/lib/wordfenceHash.php on line 186

    Wordfence Memory benchmarking utility version 6.1.17.
    This utility tests if your WordPress host respects the maximum memory configured
    in their php.ini file, or if they are using other methods to limit your access to memory.

    –Starting test–
    Current maximum memory configured in php.ini: 320M
    Current memory usage: 90.50M
    Setting max memory to 90M.
    Starting memory benchmark. Seeing an error after this line is not unusual. Read the error carefully
    to determine how much memory your host allows. We have requested 90 megabytes.
    Completing test after benchmarking up to 90.50 megabytes.
    –Test complete.–

    Congratulations, your web host allows you to use at least 90.50 megabytes of memory for each PHP process hosting your WordPress site.

Viewing 1 replies (of 1 total)
  • Hi emill,
    Do you have folders with large number of files? it could be a caching plugin that stores too many files on your server, if this the case, you can exclude these folders from the scan by adding them to “Exclude files from scan that match these wildcard patterns” option under (Wordfence > Options => Scans to include).

    I would also suggest disabling all your other plugins, then go to (Wordfence > Diagnostics) and scroll down the page to choose “Enable debugging mode“, after that go to (Wordfence > Scan) and click on “Start a Wordfence Scan”, paste any errors you may get here to check and don’t forget to turn off the “debugging mode” after you finish this process.

    Let me know how it goes,
    Thanks.

Viewing 1 replies (of 1 total)
  • The topic ‘Wordfence memory exhausted’ is closed to new replies.