Support » Plugin: Wordfence Security - Firewall & Malware Scan » Wordfence is detecting wrong IP, and locking me out

  • Resolved winterstreet

    (@winterstreet)


    I’ve tried changing the setting for how Wordfence detects the IP address, but it doesn’t change anything. The site is hosted with Siteground. Not 100% sure but I think the IP that shows is from Siteground, but it’s not the shared IP for the hosting account. The live traffic setting is set to security only, it looks to me like others (bad people trying to login) are showing as the same IP address. So then we all get locked out. I’ve also tried deactivating the other plugins and clearing the cache, but it still shows the wrong IP 146.66.68.87

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support wfscott

    (@wfscott)

    @winterstreet

    Could you please send diagnostics to wftest@wordfence.com and put your forum username in the second corresponding field. That is at Wordfence > Tools > Diagnostics > Send Report by Email.

    Please respond here when those are sent.

    Thanks,
    Scott

    Thread Starter winterstreet

    (@winterstreet)

    It’s sent. Thanks for the assistance.

    Plugin Support wfscott

    (@wfscott)

    Thanks for that. I’m not seeing the correct IP come over, as you mentioned it appears to be SiteGround’s.

    Double-check by grabbing your IP address here:
    https://www.whatsmyip.org/

    Then in Wordfence > All Options > General Wordfence Options in the How does Wordfence get IPs area click each option and check the two fields just below, which are Detected IP(s) and Your IP with this setting. Those should read the same as your IP you checked above at the link.

    If you see the SiteGround IP address at the bottom for those two options still, that would suggest that the Nginx proxy server may not be configured properly and you should check with SiteGround to assure that visitors IP addresses are being detected correctly and passed to the webserver.

    Let me know what you see there, please.

    Scott

    I’ve just edited my response because I see that Scott has just responded to you.

    • This reply was modified 1 year, 3 months ago by WFGerroald.
    Thread Starter winterstreet

    (@winterstreet)

    @wfscott I had already tried what you described before posting, and I still see the wrong IP address. I’ll check with Siteground support, and reply back here if I find out anything useful.

    Thread Starter winterstreet

    (@winterstreet)

    I heard back from Siteground. The issue is that the site was migrated to a different server and since DNS uses an A record there’s some sort of redirect happening to the new IP address. They had notified the site owner about the migration, but that information never made it to me. I’m pretty sure once the DNS gets updated that the problem will be solved. Thanks.

    Plugin Support wfscott

    (@wfscott)

    @winterstreet

    Thanks for the update. Please feel free to reach out if you have any other questions.

    Thanks,
    Scott

    @winterstreet — Did you resolve this? I’m also on SiteGround and troubleshooting the same issue, where I have the same IPs which are SG’s showing up regardless of option I choose. Thanks!

    Thread Starter winterstreet

    (@winterstreet)

    @wfscott updating DNS fixed the problem.

    @winterstreet thanks, followed some other threads and found out that we do actually have an A-record notice on the hosting, so that should fix it!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Wordfence is detecting wrong IP, and locking me out’ is closed to new replies.