Support » Plugin: Wordfence Security - Firewall & Malware Scan » Wordfence is causing site problems

  • Resolved waveout

    (@waveout)


    Hey,

    Wordfence is causing site problems. So I have tried to investigate the problem further and have come to the following. The problem may be the wordfenece security plugin. Since I have tried switching to other themes, reset wordfence settings to deafult and disabeling all plings except wordfence.

    Anyone who have experienced something similar or know about this problem?

    Thanks 🙂

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • billyf

    (@excited4coupons)

    same here. I had to disable and remove wordfense and change to iThemes Security until hopefully the plugin support figures it out.

    Thread Starter waveout

    (@waveout)

    Okay, weird. the problem must be fairly new then. But thanks for your reply. 🙂

    Hey @waveout,

    Can you please elaborate on what’s happening? Can you please share screenshots of any errors?

    Please let me know.

    Thanks,

    Gerroald

    I’m getting a fatal error (Plugin could not be activated because it triggered a fatal error) when trying to reactivate Wordfence – not sure if this is related to what others are experiencing. Has there been an update today?

    Hey @garyjh28,

    There has not been an update today, though it’s quite possible that it is the same issue that others are experiencing.

    Can you please share your system/server information including your PHP resources found in WordPress > Health Check?

    Thanks,

    Gerroald

    • This reply was modified 1 year, 3 months ago by WFGerroald.

    Hi @wfgerald ,

    I’ve been able to fix this by uninstalling WF and then use the WF Assistant to delete the WF tables and data.

    I’ve sent a diagnostics report via WF with my forum username.

    Details are:
    ### wp-core ###

    version: 5.4.1
    site_language: en_GB
    user_language: en_GB
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 540
    dotorg_communication: true

    ### wp-paths-sizes ###

    advanced-cache.php: true

    ### wp-active-theme ###

    parent_theme: Extra (Extra)
    theme_features: custom-background, automatic-feed-links, post-thumbnails, title-tag, et-post-formats, et_widget_areas, html5, lifterlms-sidebars, widgets, menus

    ### wp-parent-theme ###

    name: Extra (Extra)
    version: 4.4.8
    author: Elegant Themes
    author_website: http://www.elegantthemes.com

    ### wp-themes-inactive (1) ###

    Twenty Seventeen: version: 2.3, author: the WordPress team

    ### wp-mu-plugins (1) ###

    installatron_hide_status_test.php: author: (undefined), version: (undefined)

    ### wp-plugins-active (36) ###

    Advanced Comment Form: version: 1.2.0, author: Thomas Maier
    Akismet Anti-Spam: version: 4.1.6, author: Automattic
    Authors List: version: 1.1.3, author: WPKube
    Cache Enabler: version: 1.3.5, author: KeyCDN
    CDN Enabler: version: 1.0.9, author: KeyCDN
    Colorlib Login Customizer: version: 1.2.96, author: Colorlib
    Contact Form 7: version: 5.1.9, author: Takayuki Miyoshi
    Divi/Extra Layout Injector: version: 3.1, author: Sean Barton – Tortoise IT
    Easy Username Updater: version: 1.0.4, author: Yogesh C. Pant
    Enable Gzip Compression: version: 1.0.3, author: Moki-Moki Ios
    Flamingo: version: 2.1.1, author: Takayuki Miyoshi
    Header Footer Code Manager: version: 1.1.7, author: 99robots
    i2SDK: version: 3.99, author: David Bullock
    Loco Translate: version: 2.4.0, author: Tim Whitlock
    Memberium: version: 2.171, author: David Bullock
    Menu Items Visibility Control: version: 0.3.9, author: Hassan Derakhshandeh
    Monarch Plugin: version: 1.4.12, author: Elegant Themes
    PublishPress Authors Pro: version: 3.3.1, author: PublishPress
    PublishPress Checklists Pro: version: 2.1.0, author: PublishPress
    PublishPress Pro: version: 2.0.6, author: PublishPress
    PublishPress Revisions Pro: version: 2.3.5, author: PublishPress
    Redirection: version: 4.8, author: John Godley
    Shortcode in Menus: version: 3.5, author: Gagan Deep Singh
    ShortPixel Image Optimizer: version: 4.19.2, author: ShortPixel
    Term and Category Based Posts Widget: version: 4.8.1, author: TipTopPress
    UpdraftPlus – Backup/Restore: version: 2.16.26.24, author: UpdraftPlus.Com, DavidAnderson
    URL Params: version: 2.2, author: Jeremy B. Shapiro
    User Menus: version: 1.2.3, author: Code Atlantic
    User Role Editor: version: 4.55.1, author: Vladimir Garagulya
    Wordfence Assistant: version: 1.0.7, author: Wordfence
    Wordfence Security: version: 7.4.7, author: Wordfence
    WP HTML Mail: version: 3.0, author: Hannes Etzelstorfer // codemiq
    WP Mail SMTP: version: 2.1.1, author: WPForms
    WP System Info: version: 1.3, author: Nurul Amin
    WP User Avatar: version: 2.2.6, author: ProfilePress
    Yoast SEO: version: 14.3, author: Team Yoast

    ### wp-plugins-inactive (8) ###

    Autoptimize: version: 2.7.3, author: Frank Goossens (futtta)
    Infusionsoft Landing Pages: version: 1.3, author: Infusionsoft & David Bullock
    Infusionsoft Official Opt-in Forms: version: 1.0.5, author: Infusionsoft
    Jetpack by WordPress.com: version: 8.6.1, author: Automattic
    PublishPress Permissions Pro: version: 3.1.6, author: PublishPress
    Regenerate Thumbnails Advanced: version: 2.3.0, author: ShortPixel
    Resize Image After Upload: version: 1.8.6, author: ShortPixel
    SeedProd Coming Soon Page Pro: version: 5.12.5, author: SeedProd

    ### wp-media ###

    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-68 Q16 x86_64 2020-04-01 https://imagemagick.org
    imagick_limits:
    imagick::RESOURCETYPE_AREA: 31 GB
    imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    imagick::RESOURCETYPE_FILE: 786432
    imagick::RESOURCETYPE_MAP: 31 GB
    imagick::RESOURCETYPE_MEMORY: 16 GB
    imagick::RESOURCETYPE_THREAD: 6
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: unknown

    ### wp-server ###

    server_architecture: Linux 3.10.0-957.21.2.el7.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.2.29 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 3000
    time_limit: 300
    memory_limit: 256M
    max_input_time: 600
    upload_max_size: 128M
    php_post_max_size: 128M
    curl_version: 7.69.1 OpenSSL/1.1.1f
    suhosin: false
    imagick_availability: true
    htaccess_extra_rules: true

    ### wp-database ###

    extension: mysqli
    server_version: 10.2.31-MariaDB

    ### wp-constants ###

    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined

    ### wp-filesystem ###

    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable

    Hi,
    I don’t think i have to create a new topic.
    WF crashed my website today.

    I’ve disabled the extension but i hope you can fix this

    Hi, me too. I updated it and it broke the site. I had to remove the plugin for the site to come back up. I hope it can be fixed too!

    Thread Starter waveout

    (@waveout)

    Hey @wfgerald

    The error that I could see was “Failed to load resource: the server responded with a status of 503 (Service Unavailable)” on my site.

    @garyjh28 good call on the wf assistant!

    I was having same issue and solved it with:

    1. uninstall wordfence
    2. install wordfence assistant
    3. click the uninstall all tables and data button
    4. click the uninstall firewall button
    5. reinstall wordfence
    6. go through normal setup procedure

    Same Problem – I have multiple sites and was running WordFence for a couple of years. Really liked it and a few ways it was showing attacks etc… however… I would appreciate it not breaking my site when I am fixing to leave on vacation and having to install another plugin on multiple sites and learn the ins.outs of how it works just to make it safe for hackers and such.

    (@rtpharry) thanks for the advice… question. if that works, won’t we lose the ones that have tried to hack the site already and then have to build it again? And how long before it crashes the site??

    Plugin Author WFSupport

    (@wfsupport)

    Thanks for reaching out. We’ve been investigating these reports and now think we have a cause and a solution.

    One thing to note, that if you see an error in your logs about running out of memory, it may not be the same issue. It might be a case of needing to allocate more memory to PHP. PHP memory is cumulative. That means the amount set in php.ini is shared between all your plugins, your theme, and WordPress, plus any other non-WordPress apps you have installed in the site folder. We recommend changing it to 256M and upgrading to PHP 7 or above, which introduced better memory handling. If that doesn’t help, please try one of the other solutions mentioned here.

    What we found is that on some sites the emailedIssuesList row in the wfconfig table had became too large from recording hashes of previously emailed scan issues. Reinstalling Wordfence fresh (where the data and database tables are removed) was fixing the issue but this lets us know exactly where the problem was.

    There are 2 ways of fixing this.

    1. If you are comfortable using MySQL queries you can issue this command using PHPMyAdmin in your hosting control panel:
    delete from wp_wfConfig where name = ’emailedIssuesList’;

    2. If you are not comfortable with running queries do this:
    Remove and reset Wordfence, using the Wordfence Assistant plugin to remove all tables and data and then reinstall the plugin.

    We are looking at a solution to prevent it from happening again and hopefully will include it in the next release.

    Thanks always for being patient as we worked diligently to solve this for our customers. Thanks as well for reaching out and providing valuable information to help us solve it. Let us know if this solves it for you.

    Hi,
    i did the update and tried to activate the plug-in. It doesn’t activate: i have a worpress message telling me that Wordfence causes a fatal error…

    Hey @waveout,

    We recently released 7.4.8 to address this, which has resolved the issue. Also, completely resetting Wordfence has resolved the issue. Can you please try this and let me know if it helps?

    Everyone else, if these two suggestions don’t help can you please open a new thread and we’ll take a closer look?

    Thanks,

    Gerroald

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Wordfence is causing site problems’ is closed to new replies.