Support » Plugin: Wordfence Security - Firewall & Malware Scan » Wordfence Firewall Caldera Forms –> White Page

  • Resolved Farbweiss

    (@farbweiss)


    Hello there,
    I have a strange behaviour with activated Firewall + Caldera Forms. If Firewall is active (OR in learning Mode) – I got an white Screen after I send a contact form via caldera forms. The form is NOT sent, it is NOT included into database or anything… I activated WP-Debug, no error.

    After I disabled Firewall feature, the contact form worked again. Do you have an idea, what to do – how can i configure that kind of “exclusion rule” (Add Whitelisted URL/Param:) for sending Caldera Contact Forms…

    I don´t want to stop using Caldera Forms and I want to use Firewall Feature, too 🙂

    WordPress: 4.5.3
    Caldera Forms: 1.3.5.3
    Wordfence: 6.1.10

    Thanks in advance!
    Manuel

    https://wordpress.org/plugins/wordfence/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hello Farbweiss,
    I will look in to this further but just to exclude the possibility of a conflict did you check your servers error logs to see if there is anything in there that could be related? Thanks in advance!

    Hello, thank you for your answer,

    I looked: nothing inside error logs regarding caldera forms triggering.

    I tried to get Add Whitelisted URL/Param: for the url with contact form. No luck with “request.headers” or “post body”.

    Then I activated in caldera Forms: “ajax submission”. Now it works. So as long as no “real” page load is triggered after sending forms, it seems to work – no “white screen of death” and the form is in database, too.

    Hello again Farbweiss,
    I’m guessing there is something about Caldera forms that the Firewall doesn’t like but I’m not sure what exactly it is.

    You should not be getting a whitescreen though that’s not good. You could try keeping a browser console open to see if it’s possibly a javascript error preventing the page from loading. If you are up for it you could send me a diagnostics report too that I can keep and compare with in case I see this issue popping up again.

    Go to Wordfence “Diagnostics” page and at the bottom click the button that says “Send Report by Email”. Change the prefilled address to asa@wordfence.com and please provide your username so I know who the mail is coming from.

    Hello again Wfasa,

    thank you for the reply. Some more things, I can report / say about this incident. On a different project (nearly same settings, same hosting, same wordpress, caldera forms etc.) I did not get this “white death”. I realised, on that second project, there is no “falcon cache” active, like in the first project.
    And on a third project, no caldera forms but Contact Form 7 + Wordfence + Cache –> it works, too.

    Anyway I will have a look at this again, right now it is working with “ajax reload on”. You can put this ticket into “queueing mode” – I am off computer for some days. But will get back to you, after that.

    All the best,
    Manuel

    Thanks Farbweiss, I’ll be here when you want to keep digging.

    Hello again 🙂
    I have the same problem now on another website. I am not really sure, but either it is the caching (comet cache) or active firewall on a page with caldera forms.
    If I want to exclude a page / usage of the form, what do I have to enter in WAF – if the webform on this page?
    https://domain.ltd/contactform/

    ? Thanks and Regards,
    Manuel

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Wordfence Firewall Caldera Forms –> White Page’ is closed to new replies.