Support » Plugin: Wordfence Security - Firewall & Malware Scan » WordFence crashing WordPress 4.0 site with Fatal Out of Memory Error

  • Resolved gaffer.wiles

    (@gafferwiles)


    SInce WordFence has upgraded from 5.1.9 I am getting errors when browsing to the site:

    Fatal error: Out of memory (allocated 33292288) (tried to allocate 616 bytes) in /…/wp-content/plugins/wordfence/lib/wfBrowscapCache.php on line 49719

    Only way I was able to get my site back was to go to the dashboard and set WordFence to Level O (All WordFence security measures disabled)

    I did remove WordFence completely and reinstall manually via FTP and activation of Plugin but problem returns. SO I am deactivating WordFence until the problem is resolved.

    http://ags-ligenlewe.com

    https://wordpress.org/plugins/wordfence/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author WFSupport

    (@wfsupport)

    Hi

    Sorry you are having issues with the plugin.

    This is an indication that your memory in php.ini is not set high enough. You can define this in your php.ini file (usually found in /etc on linux systems check your documentation for windows servers). Look through he file for a line like this:
    memory_limit = 128M
    Keep in mind the 128M is probably different. That’s the amount of memory that php is allowed to consume. If you have 10 plugins and combined they consume more memory than you have allocated, you’re going to have problems. You can assign more by increasing this value. (my personal sites have 256M allowed, but this is for a pretty big site with a substantial number of hits and plugins). Make sure and restart httpd (apache) after making changes there.

    That should fix the issue.

    tim

    Sorry to jump in but I was having the same issue. It was a conflict between wordfence and SEO Ultimate. so @gaffer.wiles if you have it, just deactivating and see if it fixes the issue.

    No I don’t have SEO Ultimate installed as a plugin. My WordPress host 1&1 has a 32Mb limit on the memory available for WordPress installs. WordFence worked well up to it’s last version but now it bugs out with a memory error. I have disabled it. I could upgrade to a higher package with more memory, (at a higher cost to me) but that defeats the purpose of the issue – that being the latest version of WordFence uses more memory.

    Plugin Author WFSupport

    (@wfsupport)

    I think you may be able to work around that by defining it in your wp-config.php file but if it’s shared hosting it might not work. Try adding one pf these lines:

    define(‘WP_MEMORY_LIMIT’, ’64M’);
    define(‘WP_MEMORY_LIMIT’, ’96M’);
    define(‘WP_MEMORY_LIMIT’, ‘128M’);

    I’d start with the 64M one and see if that helps.

    tim

    Ugh! One of the best programs around for protecting my website is continuously running out of memory on my installation.

    I’m going to upgrade from 5.2.9 to 5.3.1 and hope this problem is resolved.

    I’m not sure whether or not it’s related to recent WordFence updates (they have been several in the last few weeks) but I’m getting fatal errors from scans and scans that fail to complete. This is very annoying.

    This used to be an awesome product. I have both the paid and free editions installed on different sites and have this problem across them all.

    It’s a deal killer.

    Plugin Author Wordfence

    (@mmaunder)

    This is not a bug in Wordfence. 32 megabytes is not enough to host a modern WordPress installation.

    I’m surprised that Wordfence works at all on 32 megabytes. Our minimum recommended memory for running WordPress with Wordfence is 64 megs. Here are our system requirements with some additional info:

    http://docs.wordfence.com/en/Wordfence_system_requirements

    Regards,

    Mark.

    I have upgraded to a higher package on my hosting company which will give me a bit more PHP memory. Costs a lot more, but I hope the investment will be worth it albeit just to get WordFence to work.

    I had this problem, but wanted to find the root cause instead of increasing memory. It turns out that PHP5.4 uses way less memory than PHP5.3, on the order of 18MB for my WordPress installation! Upgrading my server to PHP5.4 solved my problem. Save your money on memory and just upgrade PHP.

    Thanks,
    Brian

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WordFence crashing WordPress 4.0 site with Fatal Out of Memory Error’ is closed to new replies.