Support » Plugin: Wordfence Security » Wordfence could not get an API key

  • Resolved redsentence

    (@redsentence)


    Hi there. I am trying to get Wordfence to install on a site hosted with Yahoo. I am getting the following error:

    Wordfence could not get an API key from the Wordfence scanning servers when it activated. You can try to fix this by going to the Wordfence “options” page and hitting “Save Changes”. This will cause Wordfence to retry fetching an API key for you. If you keep seeing this error it usually means your WordPress server can’t connect to our scanning servers. You can try asking your WordPress host to allow your WordPress server to connect to noc1.wordfence.com.

    When I run a connectivity test, I am getting the following error:

    STARTING CURL http CONNECTION TEST….
    Curl connectivity test passed.

    STARTING CURL https CONNECTION TEST….
    Curl connectivity test passed.

    Starting wp_remote_post() test
    wp_remote_post() test to noc1.wordfence.com passed!

    Starting wp_remote_post() test
    wp_remote_post() test to noc1.wordfence.com failed! Response was: error:0D0890A1:asn1 encoding routines:ASN1_verify:unknown message digest algorithm

    Any ideas on what is happening here please? Many thanks!

    https://wordpress.org/plugins/wordfence/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi,

    Try this. Scroll to the bottom of the Wordfence “options” page. Check the box to remove Wordfence data on deactivation. Deactivate and reactivate. That would be the first thing to try.

    Yahoo may block the connection though. Anyone else using Yahoo hosting and Wordfence together?

    -Brian

    Hi Brian,
    Thanks for the reply I did try that with no luck unfortunately.

    Thanks
    Jason

    I’m having a similar problem with WordFence and Yahoo Small Business. About 1 month ago, WordFence stopped completing security scans and reported back with the following error code:

    error:0D0890A1:asn1 encoding routines:ASN1_verify:unknown message digest algorithm

    I talked with Yahoo Small Business tech support today and mentioned what I had discovered after talking with the WordPress tech support and Googling the error code along with “wordpress.”

    From WordPress’s servers, it looks like Yahoo is using an outdated version of cUrl or Open SSL. The Yahoo rep reported back that Yahoo uses a customized version of Open SSL and it was up-to-date.

    I’m going to try contacting Yahoo Small Business through social media (Facebook messaging) and see if this works any better than the phone call.

    Thanks,
    Steve

    Has anyone made progress on this Yahoo! hosting issue???

    Plugin Author WFMattR

    (@wfmattr)

    If you are still getting the same message on Yahoo’s hosting, they may still need to update curl or OpenSSL. I found an older thread about WordPress updates having a similar issue — in that case, someone from wordpress.org mentioned that the host may not support SHA-256:
    https://wordpress.org/support/topic/cannot-update-my-wordpress-version

    Yahoo may have their software updated, but since they’re using a custom version, they may not have enabled support for SHA-256, and may not realize that it is causing problems.

    In Wordfence, at least, you might be able to at least get scans to run if you turn off “Enable SSL Verification” near the bottom of the Options page. This generally isn’t recommended, but if it is the only way to get the scans working, it may be helpful — but it still may not be enough to fix the problem. Let us know if you do try it.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Wordfence could not get an API key’ is closed to new replies.