Support » Plugin: IP Geo Block » WordFence Conflict

  • Resolved Ike Ten

    (@ike-ten)


    Thanks for the plugin.
    It works great for blocking access to only admin back end which makes lots of sense and very handy too.

    The only issue is that when activated together with WordFence (free) security plugin, the ‘Wordfence Scan’ does not work. When I click ‘Start WordFence Scan’. It only displays ‘WordFence is requesting scan’ but it does not scan.

    Also does the plugin support ISO 3166-2 country subdivisions example US-NY?

    Kindly assist. And thanks again for the plugin, it helped block many attempted logins.

    • This topic was modified 2 years, 10 months ago by  Ike Ten.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi @ike-ten,

    Sorry for your inconvenient. I’ll fix this issue without taking so long time.

    And as for ISO 3166-2 country subdivisions, this plugin doesn’t support it because free version of geolocation API and database doesn’t support it.

    Thank you for your reporting this issue.

    Thanks for responding.

    Update:

    After playing around this it seems WordFence only works when Validation timing set to —“init” action hook
    After reading your documentaion it seems the =“init” action hook= is slow than the ==ip-geo-block-mu.php== setting

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi good cache, @ike-ten.

    The direction of my solution has been clear by your nice report.
    Thanks a lot!

    Good to know it helps you.

    I just want to point out that all the other features of WordFence works, except the scanning.

    I first thought it was IP Geo Block blacklisting the wordfence remote server but further troubleshooting revealed that even after white-listing wordfence remote servers, scanning still did not work.

    The update you pushed solved the scanning conflict. Thanks for working hard to fix this.
    I would test it to see any issues henceforth.

    Best Regards.

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Dear @ike-ten,

    I appreciate your response and closing this issue. (Actually, there are some people who opens issue but do not respond that decreases my motivation.)

    Thanks a lot!

    • This reply was modified 2 years, 10 months ago by  tokkonopapa.

    U are most welcome @tokkonopapa

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WordFence Conflict’ is closed to new replies.