Support » Plugin: SQLite Integration » Wordfence compatibility issues?

  • I used to run all my PHP stuff on MySQL but recently switched to SQLite

    I’ve got a new installation of WordPress 4.4.2 using the SQLite Integration plugin v. 1.8.1 with SQLite3, PHP 5.5.9 with Suhosin on Apache 2.4.7, all on Ubuntu 14.04 64-bit.

    Also installed the latest version of Wordfence – 6.0.24

    It’s all working pretty well except I get an odd warning when saving the wordfence settings. Entry in apache2 error log:

    [Fri Mar 04 02:11:36.302925 2016] [:error] [pid 9446] [client 104.235.7.214:33229] PHP Warning: implode(): Invalid arguments passed in /srv/www/html/blog/wp-content/plugins/sqlite-integration/query.class.php on line 709, referer: https://www.<my domain>.org/blog/wp-admin/admin.php?page=WordfenceSecOpt

    Also, the wordfence scans stop midstride with a similar error:

    [Mar 04 01:47:12] Notice: Undefined offset: 1 in /srv/www/html/blog/wp-content/plugins/sqlite-integration/query.class.php on line 683

    And I cannot start a new scan after this error has shown up, even after killing a scan.

    I’ve tried disabling Suhosin and it doesn’t help, either.

    Anyone else running Wordfence with SQLite?

    https://wordpress.org/plugins/sqlite-integration/

  • You must be logged in to reply to this topic.