Support » Plugin: Wordfence Security - Firewall & Malware Scan » WordFence Blocks cURL and the REST API

  • This issue began when WordPress rolled the Health Check plugin into WordPress.

    Up to today I dismissed the cURL 28 timeout error and REST API connection error as being a bug in Health Check. I was lead down that path by other reports of a bug in Health Check that causes Health Check to erroneously report issues with cURL and thus also with REST API connectivity.

    I use two plugins in two different sites that rely on cURL and the REST API to function. Neither plugin has worked properly since Health Check arrived. However, when Wordfence is disabled both plugins work splendidly.

    I suspect Wordfence is is blocking cURL, and so REST connections too.

    Is there or are there Wordfence settings I need to change?

    Does Wordfence conflict with the Health Check plugin?

    Either way, there is an issue and Wordfence (probably other security plugins too) seems to be the culprit.

    Thanks for your help.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support wfdave

    (@wfdave)

    Hi @leehodson,

    Can you try disabling Prevent discovery of users through WordPress REST API within Wordfence -> All Options -> Additional Options?

    For example: https://i.imgur.com/NA2UM3m.png

    Another thing you can try is by putting the Wordfence firewall under Learning Mode (via Wordfence -> Firewall -> Manage WAF.

    For example: https://i.imgur.com/iEkIlyt.png

    Dave

    Thank you for your quick reply.

    I have tried ‘Prevent discovery of users through WordPress REST API’ already but it had no impact.

    I will see what happens when we put the firewall into Learning Mode.

    Learning Mode made no difference. Anything else you need me me to try?

    You can test for the issue internally by using WP Google Maps Pro to collect map data from Google Maps using the Google Maps API. Version 7.11.35 will be best to test with. The plugin developer added an ajax fallback in version 7.11.36 for cases where the REST API is blocked.

    Plugin Support wfdave

    (@wfdave)

    Hi again,

    I’ve installed the plugin myself and it seems to work fine.

    I’d like to get a bit more information about your setup, can you go into Wordfence -> Tools -> Diagnostics -> Email to wftest@wordfence.com?

    Include your username leehodson in the forum/ticket name, so I know it’s you.

    Another thing that could be the issue is our usage of Google Recaptcha, so can you also try disabling Login Security / 2FA to see if that starts allowing wp-google-maps to work?

    Dave

    Hello Dave,

    I apologise for not responding sooner. The notification from this forum failed to arrive.

    I will follow your advice during today.

    Plugin Support wfscott

    (@wfscott)

    @leehodson

    I took a look for your diagnostics but I wasn’t seeing them. Did you send them over?

    Did disabling the captcha features make any difference for you?

    Scott

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.