Support » Plugin: Wordfence Security - Firewall & Malware Scan » Wordfence blocking Googlebot when using Cloudflare

  • Resolved Mark

    (@markob17)


    I recently enabled the firewall option to block fake Google crawlers, etc., and it now seems Googlebot is being blocked as my site’s new pages aren’t being indexed. Checked the Wordfence Blocked IPs log to confirm this and noticed the IPs of Googlebot are being detected as Cloudflare’s IPs.

    I found the following thread: https://wordpress.org/support/topic/wordfence-blocking-cloudflare and determined I am not using the Cloudflare WordPress plugin, however, I am using W3 Total Cache with the Cloudflare option enabled and configured correctly. According to my research, this W3 Total Cache Cloudflare option does the same thing as the Cloudflare WordPress plugin.

    At this point I am stumped and had to disable the firewall. I’m hoping you guys have solution as I would really like to continue using Wordfence but may have to switch if I cannot use the firewall features.

    Any ideas? Appreciate your help.

    Thanks!

    Mark

    https://wordpress.org/plugins/wordfence/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author WFSupport

    (@wfsupport)

    Use the cloudflare plugin. Their support guy (who is awesome, by the way!) has said it is important to do so. You could add the ip address to the whitelist to bypass all rules as well.

    tim

    Awesome, thanks for the quick reply, really appreciate it. After reading around a bit, found out about and then decided to install mod_cloudflare on my site’s VPS and it resolved the issue. Not sure if this option is better than installing the cloudflare plugin, however, things looks like they are working great now. Great plugin by the way, works like a charm and I love how it is pretty much set and forget with the auto updates. Great work!

    Thanks,

    mark

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Wordfence blocking Googlebot when using Cloudflare’ is closed to new replies.