Support » Plugin: Wordfence Security - Firewall & Malware Scan » Wordfence blocking Composer package autoload

  • Resolved simonreading

    (@simonreading)


    I have a GoCardless payment gateway installation.
    (which was functioning correctly)

    This has two Composer package requirements:
    Dotenv\Dotenv class (for the private keys)
    GoCardlessPro\Client (the main client class)
    They are mounted via require_once(‘vendor/autoload.php’)
    This throws no errors:
    but as soon as you access either class, you get –
    “Fatal error: Uncaught Error: Class ‘GoCardlessPro\Client’ not found”

    Disable Wordfence – and the problem disappears (and all functions as normal)

    Am I missing some kind of Firewall setting to allow Wordfence to work with Composer?

    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support WFGerroald

    (@wfgerald)

    Hey @simonreading,

    Can you please switch the Firewall into Learning Mode? Once you’ve done this try running the actions to see if it works. If it does Wordfence will record the actions and you can reenable it.

    https://www.wordfence.com/help/firewall/options/

    Please let me know how it goes.

    Thanks,

    Gerroald

    Many thanks: It is a recent install – so it was already in learning mode: how do I see the actions / pass them to you?

    Good Morning @wfgerald

    The GoCardless plugin (via Composer) is loaded as part of the front page – there is no specific action to run other than visiting the page.
    I have re-enabled Wordfence (in Learning mode) and the problem returns.

    What I don’t know is how to get at or interpret any of the logs – or to see where the action/reaction Wordfence has taken to block the perceived attack is recorded

    I can’t leave a public facing site in “Error mode” – so have to deactivate Wordfence again.

    Many thanks

    Plugin Support WFGerroald

    (@wfgerald)

    Hey @simonreading,

    I’m speaking with the developer about this. He mentioned he doesn’t believe the WAF should be blocking it, but it’s worth testing. Can you please completely disable the WAF and let me know if it helps? If it does, we can narrow it down from there.

    https://www.wordfence.com/help/firewall/#disabling-the-firewall

    Please let me know how it goes.

    Thanks,

    Gerroald

    Plugin Support WFGerroald

    (@wfgerald)

    Hey @simonreading,

    He also mentioned that you might enable WP_DEBUG to see if it turns up any errors.

    https://codex.wordpress.org/WP_DEBUG

    Thanks,

    Gerroald

    Many thanks for your ongoing attention – I will have to follow your steps tomorrow (this has caused a bit of a backlog trying to fix) -For now, All I can mention is that we have GoCardless installed like this on a number of sites (with different templates & which have been running for “ages”) & I have installed Wordfence on a number of them with exactly the same result…, So I would guess this is not an aberration. – I will get back to you with results as soon as I can
    thanks again

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Wordfence blocking Composer package autoload’ is closed to new replies.