Support » Plugin: Pods - Custom Content Types and Fields » WordFence and Pods forms

  • Resolved davetavres

    (@davetavres)


    I got Pods setup, with a public form saving. It was working great… then… I installed WordFence and followed the instructions to set it up on SiteGround – which includes editing the php.ini file.

    As soon as I did that, the public Pods form started returning this error when someone tried to save the form – “Error: access denied for your session, please refresh and try again”

    Once I deleted the WordFence plugin – and backed out the instructions for editing the php.ini file with the PHP Variables Manager, the form started working again.

    I found support topics about checking the “Session Save Path”. After installing WordFence, mine was blank. After removing it and fixing the php.ini stuff, it now says “Session Save Path: /tmp” – and the public form works.

    So the question is… how do I (we) use WordFence with Pods public forms?

    What settings do we need to set/change for public forms to work with WordFence?

    How/where do you set the “Session Save Path” manually?

    Thanks all! 🙂

Viewing 1 replies (of 1 total)
  • Plugin Author Jim True

    (@jimtrue)

    You would need to open a Bug Report on this one and since I’m guessing you’re using Wordfence Premium, we’d need you to open an issue report with them as well and reference our bug report so we can work with them towards resolution.

    https://github.com/pods-framework/pods/issues/new/

    Sounds like the form itself (and the paths for anonymous forms/session variables) would need to be isolated from the Wordfence security.

Viewing 1 replies (of 1 total)
  • The topic ‘WordFence and Pods forms’ is closed to new replies.