Support » Accessibility » Wordfence accessibility broken

  • Wordfence 6 was fairly accessible. That accessibility is seriously broken in Wordfence 7. Specifically, checkboxes are no longer read as checked/unchecked. Dropdown lists seem to have also become somewhat difficult to navigate. I cannot recommend that any screenreader users use Wordfence at this point, at least if they wish to be able to use anything but the default options. It’s too bad, too, because it’s a good plugin, but no longer so for those who depend on screenreaders. I’ll post back here if I find another plugin I like as a replacement &/or if they choose to fix the broken accessibility.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Steve Stern


    Guardian of the Interwebs

    Have you posted in the Wordfence support area where they’re more likely to see this?

    I have, Steve. This is just kind of a heads-up for any screenreader users who might stumble across it. They recently updated it, but nothing was done re: the accessibility issue, unfortunately.



    Actually Jackie, your complaint about the check boxes was addressed. Unfortunately, we can’t just throw out an untested change without implementing and testing it first which takes time. You asked for the check boxes to be returned to a normal looking checkbox, which we did. You can see what the change looks like here.


    Tim, I’m rather suspecting that was an image? If so, then, unfortunately, those using screenreaders can’t interpret them.

    The problem is not what the checkbox looks like per se. The problem is does the screenreader know what sort of object it is, & its state. That part was (& still is) seriously broken. &, unfortunately, for those sight-impaired folks who need or want to change the options, then I can’t recommend Wordfence to them till this gets fixed.

    As for testing, the concept was working quite well in v. 6. So it has, I should think, been tested fairly extensively, no?

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.