Support » Plugin: Wordfence Security - Firewall & Malware Scan » Wordfence 7.3.6 Caused Fatal Error

  • Resolved c8rls

    (@c8rls)


    Error report when logging in using recovery mode:-

    An error of type E_COMPILE_ERROR was caused in line 75 of the file /home/REDACTED/public_html/wp-content/plugins/wordfence/wordfence.php.

    Error message: require_once(): Failed opening required ‘/home/REDACTED/public_html/wp-content/plugins/wordfence/lib/wordfenceClass.php’ (include_path=’.:/opt/alt/php70/usr/share/pear’)

    Have deactivated, uninstalled and reinstalled and the same error occurs, any ideas?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hey @c8rls,

    This sounds like a WordPress plugin update that didn’t go well. I know you mentioned you’ve reinstalled Wordfence. But can you please try completely reinstalling/resetting Wordfence and let me know if it helps?

    https://www.wordfence.com/help/advanced/remove-or-reset/

    Please let me know how it goes.

    Thanks,

    Gerroald

    • This reply was modified 2 years, 9 months ago by WFGerroald.
    Thread Starter c8rls

    (@c8rls)

    I have just checked and the include file wordfenceClass.php called by the line

    require_once(dirname(__FILE__) . ‘/lib/wordfenceClass.php’);

    Is not included within the ‘lib’ directory of the plugin.

    Thread Starter c8rls

    (@c8rls)

    Have done a complete delete and uninstall using WF Assistant and then a fresh reinstall and the same issue.

    Another of my sites has also just upgraded automatically and the same issue on that site.

    Thread Starter c8rls

    (@c8rls)

    After a little bit of investigation, the file wordfenceClass.php was being downloaded each time but the file was being removed by cpGuard virus scanner.

    Clearly a false positive but of concern that this should happen, we have lost over 15 WordPress sites this evening because of this, we have white listed the file now and are recovering them all.

    Hello, I am also having the same problem, since the last update 7.3.6 the WAF cPGuard Detects the Wordfence file as malicious. Although I add the exception to the cPGuard registry, it still deletes the file. My system is based on LiteSpeed ​​Web server. The only solution that worked, was to completely eliminate Wordfence. I have 10 sites with this problem

    • This reply was modified 2 years, 9 months ago by webmaster8rx.

    Hey @c8rls,

    Just an update. The developers were able to reach cpGuard and received this information.

    Thank you for the report. We have already taken corrective actions against the reported issue as soon as we were alerted about it. Our update will be propagated to the respective systems during the next rules update schedule today.

    Thanks,

    Gerroald

    • This reply was modified 2 years, 9 months ago by WFGerroald.
    Thread Starter c8rls

    (@c8rls)

    Thank you

    It appears that cpGuard have now pushed out updated virus definition files and the issue is now resolved.

    Hey @c8rls,

    Thanks for the update, and happy to hear it!

    Please let us know if anything else comes up.

    Thanks,

    Gerroald

    I’m still having this problem. I have installed the new version (had to uninstall it completely because the line 75 error was keeping me from even logging into my wordpress isntallation). My host did that for me a few days ago. After that, I tried to install from the WordPress store, only to get an error: Could not create directory. So I got onto my host again, they manually created the directory and the install went in.

    —————–
    Current problem: can’t activate. Get the line 75 error:
    Warning: require_once(/home/janwhita/public_html/wp-content/plugins/wordfence/lib/wordfenceClass.php): failed to open stream: No such file or directory in /home/janwhita/public_html/wp-content/plugins/wordfence/wordfence.php on line 75

    Fatal error: require_once(): Failed opening required ‘/home/janwhita/public_html/wp-content/plugins/wordfence/lib/wordfenceClass.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/janwhita/public_html/wp-content/plugins/wordfence/wordfence.php on line 75
    ————————-

    I’ve left it installed, but not activated because it hasn’t blocked my WordPress displaying (which the first problem had), and I can log into my wp-admin.

    I don’t have the virus checker mentioned in earlier posts, so that isn’t the conflict. What I do have installed and running under WordPress are: Akismet antispam and Wp-Statistics. Nothing else is activated.

    For kicks, I deactivated Akismet, but get the same error message as above when I click Activate for Wordfence.

    I love Wordfence (it fixed up some attacks that had been occuring) and we use the paid version on client sites (mine is the free version).

    Help???

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Wordfence 7.3.6 Caused Fatal Error’ is closed to new replies.