Support » Plugin: Jetpack by WordPress.com » WordAds

  • Resolved anafasia

    (@anafasia)


    I would like to test WordAds in my site, but jetpack seems to be outdated for my WordPress version. I work with version 4.2.4. and it cannot be updated as my website layout would probably be broken.

    is there any possibility of bypassing the issue? as I have said my main interest in jetpack is using WordAds.

    • This topic was modified 3 months ago by anafasia.
Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Since Jetpack is a connected service, we can only support the current version of Jetpack, which is 7.6.

    Jetpack 7.6 requires WordPress 5.1 or higher.

    I also recommend updating WordPress immediately, because you are missing several critical security fixes for now-public security vulnerabilities over the past 4 years: https://wordpress.org/news/category/security/

    anafasia

    (@anafasia)

    I cannot afford updating WordPress.

    is there any other way of using WordAds with WordPress 4.2?

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    There is absolutely no way to use WordAds under WordPress 4.2.

    Would you clarify what you mean by not being able to afford updating WordPress? WordPress is 100% free software, built and supported entirely by volunteers, and as such the updates are also 100% free.

    anafasia

    (@anafasia)

    for updating WordPress I should need to pay a coder, as I could have issues with my layout. this is what I should avoid right now.

    is there a way to contact the WordAds staff to ask them about this? I was not able to find their email.

    • This reply was modified 3 months ago by anafasia.
    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    for updating WordPress I should need to pay a coder

    You can update WordPress for free via a single press of a button at Dashboard > Updates in your site’s Dashboard.

    Anything that may no longer function after the update would be either outdated plugins or your theme. If that happens, you can simply update them from the same place, contact their support, or find a new alternative.

    Regarding alternatives, there are currently 55,155 free plugins https://wordpress.org/plugins/ and 7,448 free themes https://wordpress.org/themes/browse/new/

    If anything goes wrong beyond that, you can contact WordPress Support at https://wordpress.org/support/forum/how-to-and-troubleshooting/#new-topic-0

    However, in general nothing should go wrong. People update WordPress for free all the time, otherwise 95.1% wouldn’t be on a higher version than you. 😉 https://wordpress.org/about/stats/

    is there a way to contact the WordAds staff to ask them about this?

    Since WordAds is a part of Jetpack, Jetpack Support handles WordAds support. I’m sorry but you’ll need to update both WordPress and Jetpack to use WordAds, there is no other way around that.

    anafasia

    (@anafasia)

    as I said I cannot update WordPress. it is not a whim. I use Adsense and my gallery was designed by a coder. if the gallery breaks it will be a serious issue and I bet my income from Adsense would radically decrease.

    WordAds could be an alternative to Adsense. but with Adsense you don’t have to pay 10€ a month to use it. and it is updated for any version of WordPress. maybe AdWords could be a good complement for me to Adsense. this is why I was aiming to test it. but your answer seems to be -I’m not angry, just trying to let you understand my point of view- you have to surrender to AdWords rules, what in fact means I want be able to use AdWords, that is, you’ll be losing a potential costumer in front of Adsense.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    I understand, but we cannot provide WordAds on a version of WordPress that is over 4 years old, we simply cannot support that.

    anafasia

    (@anafasia)

    then it seems we have the same problem, I cannot afford updating my web and you cannot support updating your plug-in to old versions. a pity.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    We’ll mark this a resolved since we’re at a bit of an impasse on that, but I do want to again strongly recommend that you reassess upgrading to WordPress 5.2.2.

    As it stands, your site is now open to 4 years worth of publicly known security vulnerabilities: https://wordpress.org/news/category/security/

    Essentially you’re running out the clock between the very slim possibility of an update causing a recoverable mess or a hacker causing a non-recoverable mess.

    Any way, that is all for here. I’m sorry we are unable to help you with this, but I do hope you reconsider upgrading.

    anafasia

    (@anafasia)

    well, there’s also the option of updating your plug-in for older versions 😉

    thanks anyway, James.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Updating our plugin for older versions of WordPress will not address the past 4 years of know publicly know security vulnerabilities in WordPress 4.2.4. 😉

    The only way to address that is to upgrade to WordPress 5.2.2.

    anafasia

    (@anafasia)

    I know, but it would have allowed me to test if it would have made sense using WordAds. but you have told me there’s no option for that, so I will have to look for another alternative. thanks anyway.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.