Support » Installing WordPress » Word Press on 1and1…

  • About a month ago I installed b2 Evolution and customized the template to my liking. About two weeks later, I recieved an error that said:

    Can't connect to the database server. MySQL said:
    Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

    This frustrated me immensly. After a two weeks of pulling my hair out and lavishing my newly bald head in the sun, I decided to clear my host of all b2 related files and found Word Press. (The lack of hair must have allowed me to think more clearly.)
    Anyway I downloaded the latest version and uploaded the files. I entered my database data into the wp-config-sample.php file and renamed it to wp-config.php.
    I then went to /wp-admin/install.php and got this error:

    Error establishing a database connection! This probably means that the connection information in youn wp-config.php file is incorrect. Double check it and try again.
    * Are you sure you have the correct user/password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?

    I’m assuming this is the same problem I had with B2 Evo.
    Here is what I have in the config file:
    =
    <?php
    /** WordPress’s config file **/
    /** http://wordpress.org/ **/
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘*&*&*&*&*&*&’); // The name of the database
    define(‘DB_USER’, ‘&*&*&*&*&*&’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘*&*&*&*&*&*’); // …and password [NOT ENTERED ON FORUMS]
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = ‘wp_’; // example: ‘wp_’ or ‘b2’ or ‘mylogin_’
    /* Stop editing */
    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;
    define(‘ABSPATH’, dirname(__FILE__).’/’);
    // Get everything else
    require_once(ABSPATH.’wp-settings.php’);
    ?>

    1and1 gives me the the following Host Name:
    db37.perfora.net
    I tried to use that, but I get the same error.
    I have no hair left… what the heck is going on?

Viewing 15 replies - 1 through 15 (of 22 total)
  • I had issues with the the initial set up because the DB_host is required when using 1 and 1, even though most people don’t have to use it. Email me and I will try to talk you through it if you haven’t given up yet!

    What chmod do I need to run on my files to finish the install?
    I’m using Dreamweaver by the way.
    http://www.s92746404.onlinehome.us/

    you need to chmod the weblogs-changes-cache file to 777, otherwise you don’t need to chmod anything.

    unless ofcourse u plan to edit the templates and css files later from the backend! 🙂

    …in which case you have to chmod the files you want to edit later using the template editor interface to 766!
    -thanks Sushubh.

    I plan to do a lot of customization. I was running B2 Evolution before and was pretty confortable with editing the templates and CSS.
    I need to know how to chmod files in Dreamweaver and what files to chmod.

    The weblogs-changes-cache file is only used if you choose to show when pages that you link to are updated…doesn’t have anything to do with you posting, accessing admin, or the like. If you can’t do this right now, it doesn’t make any difference at all.

    You chmod in ur ftp client and not in dreamweaver.
    and if you using dreamweaver to upload, well there must be some option… i suggest you use an independent ftp client.
    oh boy, IE sure sucks when it comes to WP forum… :O)

    Hi can the forum admin please edit my post to remove smarcus information. I tried to edit but it gave me action not allowed??
    Thank you
    -Goran

    By the way marcus
    You have to use 1and1 hostname in order to access mysql database.
    Localhost is only if the database is running localy on the same computer your server is which is not the case with 1and1.
    Do to their security policy they are hosting mysql databases on seperate address which is perfora yourdatabasenumber.perfora.net
    so for example db45.perfora.net

    dgoran, I’ve got the database information entered correctly. I’m not sure what the problem is…
    http://www.s92746404.onlinehome.us/install/install.php
    error 403: Forbidden!
    The server understood the request, but is refusing to fulfill it. Authorization will not help and the request SHOULD NOT be repeated.

    Have you contacted 1and1 to check that the script is allowed on their server?

    No, I haven’t yet.

    1and1.com has no problems with wordpress, or any associated scripts. I have quite a few blogs up there.
    smarces, start afresh if you will, and just go through the steps again, taking care of the database stuff in wp-config properly.

    Okay, honestlty I’m just taking advantage of their free 3 year hosting plan. I will begin to pay for hosting and a domain in a few months.
    Will 1and1 help me to completely wipe my database and any files I have uploaded?

Viewing 15 replies - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.