WordPress.org

Forums

Word Press Importer Not Importing (11 posts)

  1. jerseygirl
    Member
    Posted 1 year ago #

    I had to delete my blog, but thankfully, I had a recent backup (generated by the export function - xml file).

    After reinstalling the the blog, I went to upload my xml file back into word press, but after I select the file and click "upload file and import" the next screen is blank. Nothing is imported.

    I searched the forum for a solution, but all the related posts are years old. I did take the suggestion on one post to make sure my permalink structure matches my old one, but that did not work.

    Please help! Thank you, MaggiLu

  2. webbrewers
    Member
    Posted 1 year ago #

    Did you use the same WP version?

  3. jerseygirl
    Member
    Posted 1 year ago #

    Yes. What happened was, I had to delete the database. The WP files were all still on my server. I simply created a new, clean database with the same name as the old one. WP reinstalled itself. Then, I went in and updated all the plugins, installed the WP importer plugin, and when I tried to use it, the only think I get is a blank dashboard screen.

    I really need to get my blog back online! What is the point of backing up my blog, if when I need to use the backup file, the importer does not work?

    All help, tips, appreciated.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Try checking your site's error logs for a more specific error message. Your hosts should be able to help you accessing your site's error logs.

  5. jerseygirl
    Member
    Posted 1 year ago #

    I am my own host. Nothing in error logs I can distinguish.

    [Moved to Localhost Installs]

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    Does the .xml file reference an external site?

  7. jerseygirl
    Member
    Posted 1 year ago #

    not to my knowledge. the blog has been up for many years, pretty straightforward.

    I also run many other wp blogs on our server. First time I ever saw a plugin not work as it was supposed to.

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    I've used the WP Importer dozens of times - including many times on my own local server - without the slightest problem. Perhaps the issue lies in the .xml file that you are trying to import?

    Can you import the Theme_Unit_Test successfully?

  9. jerseygirl
    Member
    Posted 1 year ago #

    ok, so you think that perhaps my theme is causing the problem? Right now I have the default theme enabled. Should I install and activate the theme I had before?

    In my estimation, that is the only thing that would be different from the prior installation.

  10. esmi
    Forum Moderator
    Posted 1 year ago #

    It's possible. Ditto any plugins installed and/or active. How did the theme unit test data import go?

  11. jerseygirl
    Member
    Posted 1 year ago #

    I haven't done it yet, but as soon as I do I will post the results.

    BTW, thanks for your help and input so far, esmi!

Topic Closed

This topic has been closed to new replies.

About this Topic