WordPress.org

Support

Support » Themes and Templates » Openstrap » [Resolved] word break and word wrap is not working

[Resolved] word break and word wrap is not working

  • I have a problem with the hyphenation/word-wrap functionality with Openstrap and I seem to be unable to figure out a solution (even though I’ve already tried your suggesstions from here http://www.opencodez.com/openstrap-responsive-wordpress-theme). Words are broken randomly and put into the next line.

    The problem occurs in Firefox but not in Chrome.

    I use WordPress in German but have all language settings adjusted so this shouldn’t be an issue.

    Do you have any suggestion on how to deal with this?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Theme Author Pavan Solapure

    @pavans

    Can you post your website please?

    my site is

    http://www.ehnur21.at

    you can find my problem here, for example: http://brag.at/hnur21/beispiel-seite/

    I also tried to use the typpgraphy plugins Hyphenator and WP Typography both of which support automatic hyphenation (and word-break, I suppose) but neither of them seems to resolve the issue.

    I have the same problem — text wrapping between consonants. Everything looks fine on my PC, and the text-wrapping function looks fine when I reduce the size of my screen (it responds). But when I look at it on any Mac product — laptop with large screen, iPad, iPhone — the weird wrapping occurs. Looks terrible! Also, my last name is broken into a hyphenated word spanning two lines (only on Mac products).

    Is it a problem running Openstrap on Macs?

    my site is apzimmermann.com

    Theme Author Pavan Solapure

    @pavans

    Look for following css

    .sidebar-right, .sidebar-left, .site-content,.entry-content, .entry-meta , article, span, a {
    	#word-wrap: break-word;
    	-ms-word-break: break-all;
    	word-break: break-all;
    
    	/* Non standard for webkit */
    	word-break: break-word;
    
    	-webkit-hyphens: auto;
    	-moz-hyphens: auto;
    	hyphens: auto;
    }

    and replace it with

    .sidebar-right, .sidebar-left, .site-content,.entry-content, .entry-meta , article, span, a {
    	word-wrap: break-word;
    }

    Let me know if this works for you.

    Pavan –
    This worked beautifully!!!! Thank you so much! I love the theme, but I would never (ever!) have figured out how to correct this problem on my own.
    I appreciate your solution and your speedy response!
    Best regards,
    Andrea Zimmermann

    Hi Pavan,

    Thank you very much for your information. I was also facing the same problem.

    Thanks & Regards,

    K G Mozumder

    Thank you, Pavan!

    The problem is gone now – everything works just fine! Awesome theme btw!

    Hello – quick question as I need to make this change to my website, whereabouts is the css that needs changing? Thanks!

    Hi, Sara,
    Go to your Dashboard
    Click on Appearances
    Click on Editor
    And then (having already highlighted the replacement coding) highlight the coding to be replaced and paste in the corrected coding.
    Good Luck!
    Andrea

    Thanks Andrea for your speedy response. Found it and replaced the coding as guided above. Unfortunately it hasn’t worked for me. My title has 27 characters, so the final word ‘consultancy’ is hyphenated (the hyphen is character #19). Is my title too long or do I need to do something else to fix this?
    Any advice much appreciated.
    Thanks
    Sarah

    Sarah,
    I am no expert, but I did try to add a word to my title/header and — although it did not hyphenate the word — it placed it on the next line. It does seem we are limited in the number of characters for the header. I forgot to see if you can choose a smaller font for your header text. You might try this. Or you might see if you can simply put the last word (“consultancy”) on the next line.

    FYI — I recently discovered if you open your site in Foxfire, the text wrapping issue is back like an ugly beast! Are you using Foxfire? Oh, and did you log out and then back in after having changed the CSS (to “refresh”?)

    Maybe Pavan will chime in here — about your issue and the Foxfire problem!

    Andrea

    Thanks again Andrea for your advice. The word ‘consultancy’ now sits as one full word underneath the the other words. All the best, Sarah

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] word break and word wrap is not working’ is closed to new replies.
Skip to toolbar