Support » Plugin: Woo Shop Slider Lite » Wooslider loading after the page content

  • Resolved JanetSlinkard

    (@janetslinkard)


    My problem is that wooslider is loading after the page content, which creates a poor user experience. Take a look at https://olivetreemortuary.biz

    I want the slider to load at the same time as the content below it, creating a seamless experience.

    I’m using wooslider as a full-width slider on my homepage. I created a Storefront child theme and added the following to functions.php in implement the slider:
    /**
    * Adds wooslider into the storefront_before_content action in the parent themes header.php file.
    */
    function wpshock_storefront_homepage_slider() {

    // if not the StoreFront Homepage Page Template return false
    if ( ! is_page_template( ‘template-fullwidth.php’ ) ) {
    return false;
    }

    // Output the WooSlider Shortcode via the do_shortcode() function.
    echo do_shortcode( ‘ .[wooslider slide_page=”homepage-slider” slider_type=”slides” overlay=”none” thumbnails=”default” link_slide=”true” display_content=”false” imageslide=”true” order=”ASC” order_by=”menu_order” size=”full”] ‘ );

    }
    add_action( ‘storefront_before_content’, ‘wpshock_storefront_homepage_slider’, 5 );

    I’ve searched and searched for a solution. I’m hoping you can help.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Aleksandar

    (@siemens82)

    Hi,

    Thanks for using Wooslider.

    The slider loads when the whole page is loaded including styles, images and other resources. The slider need to be loaded at this point when other elements are set so the Swiper slider (which is used for Wooslider) can work properly.

    You should consider using a loader for your site if you want to hide this behavior, or if you have some programming experience, override script for the slider version and make it to use document ready event. But, yes you need to write some code to avoid overwriting changes when plugin updates. You can also skip loader and fade in all your content on JavaScript window load event.

    From our experience and other users experience (in combination with visual composer usage) the window load event proved the best solution.

    Best regards,
    Aleksandar

    Thread Starter JanetSlinkard

    (@janetslinkard)

    Hi Aleksander,

    Thank you for looking into this issue for me, but I found out what was causing the problem: I had checked the option in Jetpack to “speed up images”. Once I disabled this feature, the slider loads with the rest of the page beautifully. It wasn’t a wooslider issue at all.

    Thank you for authoring such a great slider!

    Plugin Author Aleksandar

    (@siemens82)

    Hi,

    I assumed that something else is a problem as link you provided didn’t have Wooslider demo. But I’m glad you solved the problem.

    Best regards

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Wooslider loading after the page content’ is closed to new replies.