Support » Plugin: My Calendar » Woops! Updated to WP 5.2 – Grid View Events Gone!

  • This plug in worked pretty good for a while. You should know that it’s best to resize any images before uploading though. It’s not automatic. The grid view (standard calendar view) looks pretty good on a PC but when I upgraded to WP 5.2 (from 5.1) boom – no events are visible in grid view. They’re all still there and list view looks great with my new images but there’s no way to fix the grid view. Support options not included without making a purchase. Seems odd that I’d have to buy something that’s broken in order to fix it but that’s the internet for you! Also, all the event locations disappeared! I looked in the forums – na da. The plugin maker doesn’t want to be contacted directly for support. (Don’t blame you. The traffic on that would be miserable) so I’m stuck with finding something that DOES work and copying everything over. blah

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Joe Dolson

    (@joedolson)

    That sounds pretty strange; I don’t have any other reports of problems related to upgrading to WP 5.2. I do provide support in these forums, however – I’m not sure what would have given you the impression that I didn’t.

    Hi chaps. I have just encountered the same problem. All calendar entries were published and visible by all site visitors until recently. Just updated to WP 5.2.2 and zap! All entries visible by admin who entered the data BUT not by anyone else. Just happened to spot this prompted by a site user who couldn’t find their dates!! I was in default grid mode and agree with functionality notes by Mikidudle but now having second thoughts about keeping this plugin in my ‘wanted list’. Suggest Joe looks at this as a matter of urgency. I’m looking for another calendar plugin now – unless a fix occurs soon.

    Plugin Author Joe Dolson

    (@joedolson)

    I don’t currently have any information at all about this problem, as nobody has submitted a support request and I have not seen the problem myself.

    If you’re interested in pursuing support, please submit a support request; I’ll need to see an example of this in order to do any debugging.

    OK, I think I’ve solved the issue but maybe Joe can confirm. All the ‘lost info dates’ were using a customised category. When I set to ‘General’ (default with the plugin), hey presto, the dates appear on the calendar! Examining the categories, I found that the
    ‘private category’ was ticked. Umm, not sure why this was. Disabling (unticking) this solved the problem. Not entirely sure why this happened as I, the Administrator, hadn’t done this – and importantly all dates from my custom category were visible until around April/May 2019 time. My reasoning therefore indicated that it was ‘ticked’ as part of a plugin update, or my appointed ‘editor’ of the app had managed to tick it by accident, which I think is unlikely. Anyway, I have a work around for this. Joe: any comments please? Cheers, P.

    Plugin Author Joe Dolson

    (@joedolson)

    I don’t know any reason that an update would switch a category to private; but this isn’t the first time I’ve heard somebody comment on this. It is a mystery to me, however. Can you tell me what version you upgraded *from*? That would help me test the possible scenarios.

    Hi Joe. I’m afraid I can’t be definitive about the version I upgraded from. I am running 3.1.12 with WP 5.2.2 and theme Enfold 4.5.2. All info I can give you is that the issue seemed to start around April/May 2019 and that the manually invoked update to 3.1.12 was from the previous version of the plugin. I can’t remember when I manually updated but it must have been a few weeks ago. Hope this helps. Don’t want to send you on a wild goose chase. My Calendar is a great app and working fine now. Thanks for your brain power on this!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this review.