Support » Plugin: WooCommerce » Woocommerce: wp_remote_post ( ) failed . PayPal IPN

  • Paser90

    (@paser90)


    Hello,

    here my problem:
    Yesterday i can receive payment by paypal, but since this morning i got this trouble:

    I received an email this morning from paypal:

    Check the server managing the Instant Payment Notification ( IPN) PayPal . The IPN sent to the URL failed:

    https://www.———–.com?wc-api=WC_Gateway_Paypal
    https://www.———–.com/wc-api/WC_Gateway_Paypal/

    And on my wp admin statut system i got error message:

    Call wp_remote_post ( ) failed . PayPal IPN does not work with your server . Please contact your hosting provider . Country Code: 403

    i contacted my hosting about that:
    For then all are fine on they side.

    I didn’t change anything on my website to have this problem..I dont understand.
    Can anyone tell me what happen.

    Thank you very much

    View post on imgur.com

    WP Version: 4.4.1
    WC Version: 2.5.0
    WP Memory Limit: 256 MB
    Server Info: Apache/2.2.22 (Debian)
    PHP Version: 5.5.30-1~dotdeb+7.1
    PHP Post Max Size: 20 MB
    PHP Time Limit: 60
    PHP Max Input Vars: 2500
    SUHOSIN Installato: –
    MySQL Version: 5.5.4

    https://wordpress.org/plugins/woocommerce/

Viewing 4 replies - 16 through 19 (of 19 total)
  • Plugin Author Mike Jolley

    (@mikejolley)

    Paser90 So with WooCommerce disabled it’s still trying to get:

    > http://www.paypal.com/cgi-bin/webscr

    Instead of:

    > https://www.paypal.com/cgi-bin/webscr

    Which you defined in your request. Something on your install is changing http to https.

    Do one final test with ALL plugins disabled. If you get the same:

    > You don’t have permission to access “http://www.paypal.com/cgi-bin/webscr” on this server.

    You can go back to your host and tell them you’ve ruled out plugins and to check the logs/server config to see if https is supported for remote requests.

    Paser90

    (@paser90)

    Thank you Mike,
    on my last post the test was with all plugins disable (include Woocommerce).
    Now my hosting investigate more closely, i have to wait from them, and i will keep you updated. Thanks again

    Hi Good day Paser90 can you resolve this issue?

    thank in advance

    Hi, I had the same problem and traced the response from PayPal.
    It would appear that while the text of the message says:

    You don’t have permission to access “http://www.paypal.com/cgi-bin/webscr” on this server.
    Reference #18.106cd417.1481310868.8bf3e97

    the http is a red herring.
    Output from http_api_debug shows that the URL still starts with https.

Viewing 4 replies - 16 through 19 (of 19 total)
  • The topic ‘Woocommerce: wp_remote_post ( ) failed . PayPal IPN’ is closed to new replies.