Support » Plugin: Unlimited Custom Sidebars - Content Aware Sidebars » Woocommerce widgets on the “Shop” page

  • Resolved luboslives


    Hi, I have a few Woocommerce widgets in a Sidebar called “Shop Pages”. I’ve managed to get them to display on all the shop-related pages that I need them in, except for the main “Shop” page.

    Content aware sidebars is obeying all my conditions except for the very basic rule Pages > Shop (Shop Page). The rule is also present in the little widget on the page’s edit screen.

    See my screenshots here:
    edit page

    The thing is, if I move one of these Woocommerce widgets out of the Shop Pages sidebar and into my ‘Primary Widget Area’, it will display in the shop page. I know that the widgets have some sort of logic to detect if they are to be displayed – if there is anything WC-related on the page. I wonder if they’re somehow being walled off within a Content Aware Sidebars container? Or is there something hindering either the widget’s or CAS’ ability to detect that it’s on the Shop page?

    I’ve tried deleting the widgets and creating new instances within the Shop Pages sidebar, but no change – still not showing.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter luboslives



    The problem seems to be with my Shop page and any widgets within a custom sidebar. I unregistered my “Shop Pages” sidebar from the shop page and created a brand new sidebar with a simple text widget, and that text widget is refusing to show up in the shop page as well.

    Just looking through my templates, the shop page (archive-product.php) is using the exact same calls to get the sidebar that the single product pages are using, and the widgets are displaying fine on those, so it doesn’t appear to be an issue with the template…

    After further digging…

    It seems the problem boils down to CAS not detecting that it is on the Shop page. I’ve played a bit with the template files and all the possible settings in CAS, disabled any plugins that might be relevant, and nothing’s changed.

    Plugin Author Joachim Jensen


    Thank you for reporting this.

    If you want to display a sidebar on the Shop page, you shouldn’t select a specific page as a condition, but instead select “Products” and toggle Archives to ON in the condition Settings.

    The reason is that WooCommerce “takes over” the page you choose as the Shop page, so it instead becomes a Product “archive” (as explained in your 2nd screenshot).

    I think this is one of the main things in Content Aware Sidebars that confuse users, so I am open to any suggestions on how to make it more clear. Perhaps by writing “Products & Shop” in the dropdown?

    In your case:
    In your 1st screenshot, remove the Page condition, and click on Settings for the Products condition. Them make sure both Singulars and Archives are toggled to ON.

    Let me know if this solves the problem!

    Thread Starter luboslives


    Sorry it’s still not displaying any custom sidebar on the shop page. I’ve even changed the dedicated shop page setting back and forth between pages, that didn’t kick-start anything.

    I’ve commented out all my custom theme includes in case something is interfering, and still no custom sidebars show on the shop page.

    I should have this site up in a staging area this weekend if it will help to take a look at it.

    Plugin Author Joachim Jensen



    I’d be happy to take a look, just reach out to me here:


    Sorry for starting this thread again . I have the same issues as above and even after trying the above the shop page sidebars are not showing up.

    I have removed all filters and kept it simple with products and enabled the single and archive toggles on. I can see it on single product pages but not on the product catalog/shop page.


    Thread Starter luboslives


    Hi John, I never actually solved this problem for myself. It just fixed itself when I created new Sidebars on the actual live site. But the funny thing was, now that C.A.S. was recognizing the Shop page, it actually stopped recognizing the dedicated Blog page in the exact same manner.

    I ended up creating a custom template in my theme only for the blog index page, and registered a new widget area in my theme for just that page, which i then called in the template. Then I stuck what I needed into that new area through the widgets page in the admin area. Not really a solution, but it did the job.

    Thanks for your reply @luboslives . IT’s kind of wierd like you say. Somehoe its coming on mobile pages when i add it on the footer and not the same when viewed on desktop.

    Iam still new to this so let me check if I can do something abt the template you said above.

    Plugin Author Joachim Jensen



    Could you open a new support thread here:
    And in it provide a screenshot of the sidebar conditions you currently have?

    That’ll make it much easier for me to keep track of unresolved threads and help 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Woocommerce widgets on the “Shop” page’ is closed to new replies.