Support » Plugin: Custom Permalinks » woocommerce urls break after updating

  • rtwlabs

    (@rtwlabs)


    Hi, I have a client who has used your plugin for some time. Now when they update a woocommerce product the url for the product breaks creating a 404 error page despite the url being correct and the item published.

    If we delete the corresponding reference from the post type permalinks section of the plugin we can get the product to load again. However, this is far from ideal. Can you advise what might be going on and how we can fix it?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Sami Ahmed Siddiqui

    (@sasiddiqui)

    Hi @rtwlabs

    Does this only for the previously created products or for new as well? If your client didn’t test it so I recommend you to create a new product and customize the permalink of that product and see what happens with it.

    Also, does it working fine with previous WooCommerce version?

    Regards,
    Sami

    rtwlabs

    (@rtwlabs)

    Sami it’s doing it for all previously created products and a new product add as well. If you create the product and publish it with a custom url. Then go back and edit it and udpate the product content in any way the url generates a 404 error on load. You have to go in and delete the scheduled action for the product in your plugin to fix it.

    It has worked fine for older versions of Woocommerce yes as they’ve used the plugin for some time. Unsure when it broke on them as they weren’t testing the pages after updating but would have been in the last month or two I am lead to believe.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.