Support » Plugin: WooCommerce Stripe Payment Gateway » Woocommerce Stripe Webhook 400 Error

  • Resolved willaxa

    (@willaxa)


    Hello,

    Installed the “WooCommerce Stripe Payment Gateway” plugin

    Added the API for both Live and Test APIs but when I input the Webhook to Stripe I get a 400 error.

    The WordPress Timezone matches Stripe Timezone

    Thanks,
    wiL

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Stuart Duff

    (@stuartduff)

    Automattic Happiness Engineer

    Hi @willaxa,

    A 400 error indicates a Bad Request.

    The 400 Bad Request Error is an HTTP response status code that indicates that the server was unable to process the request sent by the client due to invalid syntax

    When adding your sites webhook to your Stripe dashboard did you make sure to configure that to Receive all events. You can see an example of what events are required for the webhook to function as intended within this documentation below.

    https://docs.woocommerce.com/document/stripe/#webhooks

    willaxa

    (@willaxa)

    Thanks Stuart.

    Yes I copied the webhook from Woocommerce and pasted it to Stripe Webhook and clicked on Receive all events but unfortunately it’s erroring all the time on Stripe.

    I followed the documentation from
    https://docs.woocommerce.com/document/stripe/#webhooks

    Hosting is on siteground. SSL enabled.

    Plugin Support dougaitken

    (@dougaitken)

    Automattic Happiness Engineer

    Hey @willaxa

    As a note, you don’t need all events, only those mentioned in the docs link.

    If the error happens with the Webhook secret is added, can you have a read through this and confirm that all times are matching up – https://wordpress.org/support/topic/stripe-webhook-errors/page/2/#post-12978711

    If that doesn’t work, can you roll the API keys and re-add all the secret, including webhook secret.

    Thanks,

    Plugin Support AW

    (@slash1andy)

    Automattic Happiness Engineer

    Hey there!

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.