WordPress.org

Forums

[closed] Woocommerce Store Notice Covering Top Bar in Mystile (23 posts)

  1. leanda
    Member
    Posted 1 year ago #

    Hi

    When enabling the Store Notice Text in Woocommerce it covers the the top bar containing the cart and search in the mystile theme.

    Is there anyway I can stop this from happening when the notice is enabled?

    Thanks

  2. deezlee
    Member
    Posted 1 year ago #

    I have the same question.
    thanks in advance.

  3. deezlee
    Member
    Posted 1 year ago #

    sorry for the *bump*, but does anyone know the answer?

  4. CharlyIBC
    Member
    Posted 1 year ago #

    Indeed bumping is against the rules.

    Perhaps post a link then someone might be able to help you out

  5. deezlee
    Member
    Posted 1 year ago #

    I don't have the notice activated because of the problem so there's nothing to link to.
    Thanks

  6. CharlyIBC
    Member
    Posted 1 year ago #

    I cannot help you out without a link sorry. Perhaps try looking over WooThemes documentation and forum for an answer

  7. deezlee
    Member
    Posted 1 year ago #

    Oh, I didn't realize that you were offering help! Thank you .

    The blue bar at the top of the page is the notice-bar that is covering up the cart and search area.

    I've now activated the site-wide notice and set up a test account so that you can see the site (it's under construction).

    [user crendentials moderated - do not post login info in these forums]

    Thanks again

  8. CharlyIBC
    Member
    Posted 1 year ago #

    Ummm... I need the site's URL to sign in ;)

  9. @deezlee: You're using a premium/paid theme from Woo Themes. It's best to go to the support site where you bought the theme for help with customizations and issues. You paid for support when you bought the theme, so you should contact the people who sold you the theme. These forums are for themes available in the WordPress theme directory at wordpress.org/themes/. See http://codex.wordpress.org/Forum_Welcome#Commercial_Products

  10. deezlee
    Member
    Posted 1 year ago #

    duh. geez thanks man

    http://fattysthreads.com

  11. deezlee
    Member
    Posted 1 year ago #

    Whoops, songtogtech I hadn't refreshed this thread so I didn't see your post.
    Mystile is a free theme so I don't have access to premium support.
    I've asked the question on their forum as well, but this forum is more active with experienced users.

  12. deezlee
    Member
    Posted 1 year ago #

    OK so I just I noticed that the login info has been edited.
    How do you propose that I get help on a site that is in maintenance mode?

  13. Yes, technically it's a free theme, but it is from a commercial company. Ask in the Woo forums: https://support.woothemes.com/hc/communities/public/topics/200106906-Themes Asking someone from those forums to login may be OK with them.

  14. prashantvarun
    Member
    Posted 11 months ago #

    Follow the steps Below :

    Click on Woocommerce - Settings - General - Store Notice - Untick/Unchecked Enable site-wide store notice text

    u can also check this youtube video though it is not in english but helpful
    https://www.youtube.com/watch?v=IZ0Xauu7h-A

    it will certainly help

  15. deezlee
    Member
    Posted 11 months ago #

    Yes i have the site-wide text enabled. The problem is that it covers the shopping cart links at the top of the page. Thanks.

  16. raimorrison
    Member
    Posted 9 months ago #

    I have a similar issue. I want to move store notices to be inside the page wrap or inside the product loop, but I can't find where to do that.

    Thanks!

  17. lorro
    Member
    Posted 9 months ago #

    You can alter the size and position of the notice, relative to the browser window, with some custom css, for example:

    p.demo_store {top: 50px; left: 50px; width: 20%}

    If you want to put it in a different place within the markup, you will need to alter the code and this is likely to be a lot of work.

  18. raimorrison
    Member
    Posted 9 months ago #

    If you want to put it in a different place within the markup, you will need to alter the code and this is likely to be a lot of work.

    That's exactly what i wanna do, but I can't find the place for it within the markup.

  19. lorro
    Member
    Posted 9 months ago #

    @raimorrison

    Make a child theme and put your new code in the child theme's functions.php.

    The store notice markup is in the footer. It only displays at the top due to css. wc-template-hooks.php contains the footer hook:

    add_action( 'wp_footer', 'woocommerce_demo_store' );

    You don't want to be editing WC core files because your customisations will be overwritten at next update. To remove the above hook, see this page for the function you will need to use.

    Next, make a new hook to insert the woocommerce_demo_store function where you want it to go. A list of hooks is here.

    In css, alter the p.demo-store position property from fixed to static, otherwise it will still show at the top.

  20. shawaj
    Member
    Posted 8 months ago #

    Try the following code:

    nav.col-full {
        margin-top: 125px !important;
    }
    
    /*
    DESKTOP STYLES
    -----------------
    Add styles inside the media query below that you only want to be applied to the desktop layout of your site */
    
    @media only screen and (min-width: 1028px) {
    	/* Desktop styles go here */
      nav.col-full {
        margin-top: 50px !important;
      }
    }
    
    @media only screen and (min-width: 541px) and (max-width: 1028px) {
      nav.col-full {
        margin-top: 75px !important;
      }
    }
    @media only screen and (min-width: 295px) and (max-width: 541px) {
      nav.col-full {
        margin-top: 125px !important;
      }
    }

    I need to still try and find a way that this code can automatically be injected once you enable the store-wide text but at the moment at least it is working and not covering the cart button

  21. shawaj
    Member
    Posted 8 months ago #

    Bear in mind also, that is only for the amount of text that I have in there.

    I also haven't worked out how to make it change based on the amount of text, and when it will shift from one line, to two lines, to three lines etc of text as you shrink the screen width

  22. hlanggo
    Member
    Posted 5 months ago #

    Try:

    Mystile
    Settings > Layout Options
    Enable boxed layout

    Woocommerce Site-Wide Store Notice occupies a section on top and stays there even as you scroll down. Basically an overlay. Enabling boxed layout puts more space on top.

  23. mobilewebexpert
    Member
    Posted 4 months ago #

    I had the same problem (using the Canvas theme from WooThemes). My code to solve:

    .woocommerce-demo-store #top, .wocommerce-demo-store .nav-toggle {
        margin-top: 4em !important;
    }
    p.demo_store {
        z-index: 8999;
    }
    @media screen and (max-width: 767px) {
    	p.demo_store {
    	    top: 70px;
    	}
    }
    @media screen and (max-width: 500px) {
    	p.demo_store {
    	    top: 60px;
                padding: 5px;
    	}
    }
    @media screen and (max-width: 400px) {
    	p.demo_store {
    	    top: 50px;
                padding: 2px;
    	}
    }

Topic Closed

This topic has been closed to new replies.

About this Topic