Support » Plugin: WooCommerce » Woocommerce – Stock not updating from inside dashboard

Viewing 8 replies - 1 through 8 (of 8 total)
  • Can anyone tell me how to fix?

    Caleb Burks

    (@icaleb)

    Automattic Happiness Engineer

    Something must be conflicting with WooCommerce, I can’t replicate this issue.

    Try temporarily switching back to the WordPress Twenty Sixteen Theme, or Storefront, and disable all plugins except for WooCommerce. If that resolves the issue, then slowly re-enable features until you find the one that’s causing the conflict.

    Thank you.

    I have tried disabling all plugins except woocommerce and changed theme to Twenty Sixteen.

    Unfortunately, no change. It still does not work. I update stock quantity from 0 to 1. It resets to 0 upon saving, ie. it does not save as 1.

    Please remember that I am in dashboard -> Products.

    Any other suggestions?

    Alternatively, can you tell me which table the stock quantity is stored in so that I can fix in phpmyadmin.

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    This definitely sounds like a conflict somewhere, as Caleb mentioned. Another thought is the possibility of your browser auto filling the field, have you tried in another browser?

    The quantity is meta data, so it’s in the wp_postmeta table.

    Thank you.

    I have tried Chrome, IE and Safari and all the same problem.

    I have managed to update the data using SQL. However, I would be keen to find out what the cause is so I can fix it.

    I had a failed update due to out of memory when trying to upgrade to latest version of woocommerce and then had to copy all the files across manually. Could this have caused it? The out of memory cause is now fixed.

    Can I delete the plugin and then reinstall it without losing any data? Will this possibly fix it?

    Plugin Support Thomas Shellberg

    (@shellbeezy)

    Automattic Happiness Engineer

    It’s also possible that your server’s PHP configuration is truncating the POST request. Take a look at this article for help with diagnosing and fixing this:

    http://docs.woothemes.com/document/problems-with-large-amounts-of-data-not-saving-variations-rates-etc

    Thank you for the suggestion.

    Unfortunately, it is still not working.

    I notice that the stock all have numbers in the field “edit locks”.

    Is this normal?
    Is it possible that when the update of woocommerce failed it did not set these back after setting a number in them to stop updating data whilst updating metadata? If so, how do I fix them?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Woocommerce – Stock not updating from inside dashboard’ is closed to new replies.