Support » Plugin: WooCommerce Square » WooCommerce Square Bad Performance, external paymentform js loading every page

  • Resolved xarelix

    (@xarelix)


    Previously with the WooCommerce Square plugin, you could browse the site without a js file loading every single page. The script is slow to load and takes literally 3 times longer than the rest of the elements on my page.

    How can I disable this paymentform js from loading on pages except for shopping cart and checkout pages.

    If it is absolutely impossible to disable this paymentform js, then how can I go about installing an older version of this plugin so that I can restore performance to my site.

    I appreciate the help, thank you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Jess L

    (@jlundie)

    Hi @xarelix – Thanks so much for reporting this behavior! We really appreciate this.

    We’re aware of this and have an issue open to address this in a future plugin update. I’m sorry to say that I don’t have a workaround for you at this time, but please know that we are aware of and working on this issue.

    In the meantime, you may be able to work with a developer to patch the plugin so that that script doesn’t load on non-checkout pages.

    Square 2.0+ included significant database updates. As such, we don’t recommend rolling back your site to pre-Square 2.0 – there is not a safe rollback path to older versions.

    I’m going to go ahead and leave this thread open in case any community contributors have some feedback on this, and will report back if I hear of any updates on this.

    I really appreciate the response. I rolled the entire site back from a backup, which includes the database. Going to make sure I have the latest version PRE 2.0. I will just wait to update the square plugin until this issue is resolved. Thanks again 🙂

    Plugin Support Jess L

    (@jlundie)

    Ah great – glad to hear you were able to roll back from a full backup 🙂 I’m going to mark this thread as resolved, but feel free to open another thread if you run into any other questions.

    So I updated manually from 1.0.2x to 1.0.38, but intially test payments were not working.

    I then completely disabled and uninstalled woocommerce square.
    rebooted machine.
    ssh in and manually install 1.0.38 again:

    cd /var/www/example.com/wp-content/plugins
    svn checkout https://plugins.svn.wordpress.org/woocommerce-square/tags/1.0.38/ woocommerce-square
    chown -R www-data:www-data /var/www/example.com/wp-content/plugins/woocommerce-square

    rebooted machine again.
    logged into dashboard, activated/enabled woocommerce-square 1.0.38.
    then Disconnect and Reconnect to Square in the settings, hit save.
    reboot machine third time.

    Now test orders are working, so woocommerce-square 1.0.38 is working with WooCommerce 3.8.1 for me.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.