Support » Plugin: WooCommerce » Woocommerce Shopping Zone

  • Resolved kala0202

    (@kala0202)


    I added a new Shipping Zone (Hungary), but on checkout it not showing Shipping Methods from this zone.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Shaun Kuschel a11n

    (@shaunkuschel)

    Automattic Happiness Engineer

    Hey @kala0202,

    When there are multiple shipping zones added, WooCommerce looks for the first applicable match it can find (starting at the top and going down the list) and then attempts to offer the shipping methods from that matched zone.

    To see what shipping zone is matching, you can enable shipping debug on the WooCommerce > Settings > Shipping > Shipping options page and that will display a message on the Cart and Checkout pages that says which zone is being matched.

    Also, in case it helps, here is the documentation for setting up Shipping Zones:

    https://docs.woocommerce.com/document/setting-up-shipping-zones/

    Thread Starter kala0202

    (@kala0202)

    Hey @shaunkuschel ,

    https://imgur.com/a/JHs48aK

    Yesterday I added 3 new shipping zones. 2 of them are working fine, except for this one. Still can’t find out why.

    Thread Starter kala0202

    (@kala0202)

    @shaunkuschel

    I added 10 more countries and shipping zones and half of them are showing and half are not.

    Here is the list of countries which are not showing:

    Bulgaria
    Croatia
    Italy
    Hungary
    Lithuania
    Romania

    Double-checked every setting, but can’t find where can be the problem.

    Hope you can help.

    Kind regards,
    Danylo

    Plugin Support Shaun Kuschel a11n

    (@shaunkuschel)

    Automattic Happiness Engineer

    Hey Danylo,

    Can you share screenshots of what the “Shipping” tab settings look like for an example product as well as what the Flat Rate shipping method settings are as well for one of the zones that isn’t working correctly (like Hungary)?

    Thread Starter kala0202

    (@kala0202)

    @shaunkuschel

    https://imgur.com/a/HL0vdp7

    I hope I understand you correct. If you need another screenshots let me know.

    Thank you

    Thread Starter kala0202

    (@kala0202)

    @shaunkuschel

    I solve the problem already.

    The problem was that I needed uncheck “Hide shipping costs until an address is entered” in the Woocommerce Settings.

    Anyway thank you for your time and help.

    Kind regards,
    Danylo

    Plugin Support Shaun Kuschel a11n

    (@shaunkuschel)

    Automattic Happiness Engineer

    Hey Danylo,

    Glad you got that figured out! Thanks for sharing the resolution too! 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.