Support » Plugin: WooCommerce » Woocommerce Shop Page not working

  • I am running the Customizr theme. I installed woocommerce and all of the pages work besides the “shop” page. The store is functional and I have customers buying products from my site. However, if someone goes to the checkout page and there is nothing in the cart, it directs them to “return to shop” .I have tried reinstalling any missing pages and adding [woocommerce_shop] in editing but nothing seems to work. Any feed back is greatly appreciated. When you click on “return to shop” you see this:

    Just another WordPress site

    Sample Page

    Oops! That page can’t be found.

    It looks like nothing was found at this location. Perhaps you can return back to the site’s homepage and see if you can find what you are looking for. Or, you can try finding it by using the search form below.

    Copyright © 2014 .

    Theme by ThemeHall.

    https://wordpress.org/plugins/woocommerce/

Viewing 7 replies - 1 through 7 (of 7 total)
  • My shop page does not have [woocommerce_shop] on it and works fine. Ensure that Admin page / WooCommerce /Settings / Products tab / Product Archive / Shop Page is set to the name of your shop page – defaults to Shop.

    If you have a cache plugin, delete cached pages and turn off the plugin while you are developing.

    Flush permalinks by going to Admin page / Settings / Permalinks – set to default / Save, then set to your preferred option and save again.

    If it still doesn’t work, please post your url.

    Thank you for the help. But it did not work. I checked that the shop was set as default for all of the settings and they are correct. Then deleted the cache and deactivated the plugin. Also flushed the permalinks. http://www.greeninkjax.com/store

    Disregard the above url. I mistyped. Correct url is http://www.greeninkjax.com/shop

    I think WP-Super-Cache is still running.

    The shop menu item goes to http://greeninkjax.com/contact-us/, and this is the shop page. On the shop page in the editor, have you got the permalink set to shop or contact-us?

    Thats strange. I just checked and the permalink in the edit page for “shop” and it shows http://greeninkjax.com/shop/ and I doubled checked that WP-Cache is disconnected and it is. Should I activate it, delete and deactivate again?

    If you look at the source code for the home page, right at the bottom, it shows:
    <!– Cached page generated by WP-Super-Cache on 2014-05-15 22:03:57 –>
    so WP-Super-Cache is still doing something.

    WP-Super-Cache should be activated but off: – go to Plugins and activate it, next go to Admin page / WP Super Cache, click the Delete pages button, and ensure “Caching off” is selected. Leave the plugin activated. Then refresh the home page, check the source again to see if the “<!– Cached page” etc line is still there.

    I think it would be one less thing to worry about going forward to make sure caching is off.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Woocommerce Shop Page not working’ is closed to new replies.