Support » Plugin: Paid Memberships Pro - WooCommerce Add On » Woocommerce seems to work, but not activating membership

  • Resolved Loralee_H


    I’m pretty sure I’ve missed an important step when setting up the product in woocommerce. I’ve created a “simple product” item (currently priced at 0.00 while testing), and chose the membership level I’ve just set up in pmpro.

    The front end looks like everything works (add to cart, checkout, etc), but when the customer gets their receipt there’s only a link to the product purchased, and no access to member content. And, a new user record isn’t created in Pmpro, just an order in woocommerce.

    The item is here:

    Can you spot anything obvious I may have missed? Or are there screenshots of what the product setup should look like, to make the connection between the two?


Viewing 2 replies - 1 through 2 (of 2 total)
  • I’ve since found the problem and thought I would update here in case someone else has the same challenge. Including a second problem that cropped up while I tried to fix this first one.

    1. No customer account set up
    The woocommerce product needs to have the “virtual” and “digital” checkboxes selected so that the purchase is marked complete. When the purchase is marked as complete, the customer is brought through the entire cycle, and gains access to member only content.

    [tip] add some kind of button or image during woocommerce product set up (in the Advanced > Purchase Note) to help buyers quickly get to their members only content. Initially it looks just like any other purchase in woocommerce, so adding buyer directions is really helpful.

    2. My-Account Page went into a redirect loop
    This happened after I added the [pmpro_account] to the My-Account page in woocommerce. When I removed the shortcode the redirect stops.

    Hopefully this helps someone else.


    Thanks Loralee – you’re a life-saver.

    I’ve been struggling with this for several days – so have, it appears, many others. The text actually reads ‘virtual’ and ‘downloadable’ in my version, but it worked. Seems like a big ‘miss’ for the PMPro/Woo people.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Woocommerce seems to work, but not activating membership’ is closed to new replies.