Support » Plugin: WooCommerce » Woocommerce products not showing on the product categories page.

Viewing 15 replies - 1 through 15 (of 22 total)
  • Jeasy

    (@jeasysehgal)

    Is there any solution to fix the product category issue in ver 2.1 as when you add a product, it is availabel on the catalouge search but is not visible on the main shop page or the product page.

    Jeasy

    (@jeasysehgal)

    Can anyone please help with this issue. Please!

    I had other problems with the update but I think my solution will probably work for you as well. First back up your site and or export your products so you have a local copy just in case something goes wrong.(I did not need my backup or the exported files but I still suggest taking this step first). Once you do the aforementioned step(s)… deactivate, delete and reinstall the plugin. Once you reinstall the plugin from scratch things will most likely work fine. I think there was something wrong with the update but the regular install seems to work fine. If you do not already know… certain pages will be gone and if you linked to them from a menu in the previous version you will need to reset up the linked pages which are now end-points. Good Luck.

    Jeasy

    (@jeasysehgal)

    Thanks for your response Aimdoll,

    Tried the fresh install, everything else is working apart from the product categories and shop page showing the product being added. Its driving me nuts to be honest. The problem is I can’t roll back to the previous version now as the database has been updated so am stuck on this version and until a fix is available.

    Same here. Update to 2.1. did not help – when I click product category, it shows blank page.

    i noticed that if i put stock management on with the option “hide if product is unavailable (has no stock)”. Product where not showing up even if there was enough stock. Removed the option… the products where there again…

    Maybe this could help you?

    Plugin Author Mike Jolley

    (@mikejolley)

    2.1 had an issue where “stock status” was not saved.

    To resolve this, update to 2.1.1 and then re-save your product. Thats it.

    This issue is not resolved with this solution…still broken on my end.

    Jeasy

    (@jeasysehgal)

    I can confirm that the issue is now fixed on my end. Radley, I actually deactivated and deleted the woocommerce plugin from wordpress, did a fresh install and updated all new products and set up the settings in woocommerce again. that fixed it.

    I think I took the long route, if you have just updated to 2.1.1 then simply go and resave the new products added since 2.1.0 and you will see it is fixed now.

    Hope it helps.

    I did the update from WP dashboard, and it seems to me like that is the problem. I have a feeling if I delete and reinstall 2.1.1 it might work. I have ALL kinds of problems since the update.

    If I delete WooCommerce 2.1.1, then upload a brand new version that I download from WooCommerce- what will I lose? My products? My categories? My attributes or variations?

    I know from experience that an import of my products won’t work because they have many attributes and variations- values that I spent many hours inputting into the system. I tried an import from the start, no go, so did all by hand and literally finished it today, only to have this update break it all.

    Thank you for any help, I am getting desperate 🙁

    Jeasy

    (@jeasysehgal)

    You wont loose any of your product details etc. However, I suggest installing a plugin called Duplicator and making a backup of your entire site just incase. Then just deactivate and delete woocommerce, Download a fresh install, install and update all pages from the notice you will get and you should be up and running again.

    What is your website url? Mine is

    Hi just updated to 2.1.1, set the stock again for the products… problem solved 😀

    Hi,

    I have WooCommerce v 2.1.7 WordPress v 2.9 – the latest versions.

    I have a product setup, I think correctly: it has some images and a product image and is a download – in a category.

    The shop pages just shows a category – clicking on the category returns ‘page not found’.

    There appears to be something very wrong with WooCommerce.

    I’ve tried uninstalled and reinstalling – still nothing.

    Does anyone have a solution for this? If not is there a viable, reliable alternative to WooCommerce?

    At present WooCommerce appears useless which is a great pity.

    Cheers,

    Mike

    Solution:

    #1 – go to the category section under eCommerce and choose any of the categories, then hit the link: view. It will open up a new page with the category link.For example: http://yoursite.com/product-category/wood-items

    #2Notice the category slug you have: in the example above: product-category

    #3 Go to Settings > Permalinks and then in to the option: Optional

    #4 make sure that the Product category base has the same slug you are using in the woocommerce product category.

    If they are different, then your woocommerce product category page will show blank

    Have a great day!

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Woocommerce products not showing on the product categories page.’ is closed to new replies.