Support » Plugin: Yoast SEO » Woocommerce Product conflict with Yoast

  • Resolved gtaba

    (@gtaba)


    Good evening,
    it’s been a while since I’m not able to edit the existing products or create new products using woocommerce plugin (last version 4.8.0 is installed. WordPress 5.6 is installed). After investigating the issue, I’ve tried to de-activate the Yoast plugin ( I also had installed the last version), and with the plugin not active, I’m able to edit and create new products again. So, unfortunately, it’s too important for my business to have access to woocommerce products, and I had to leave yoast not active.
    I’m using version 6.9 of Stockholm theme.
    Is it a bug of my theme, or should I try to wait for the new update of your plugin?
    Thanks for your answer.
    Best

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • I’m having the same issues. We use Divi theme. So, its probably not your theme. Just disabled all plugins on staging site and issue went away. I activated them one by one and the issue came back when I activated Yoast.

    Hi @gtaba,

    We’re not seeing the same error when editing WooCommerce products, so this seems to be something specific to your site.

    To help us troubleshoot, we’d like to get the following information:

    1. Are all your plugins and themes updated? If not, does updating solve the problem?

    2. Check for JavaScript errors in the console.

    3. Check for conflicts.

    4. Check your PHP error log for any error messages. You can do this by enabling WordPress debugging or contact your web host.

    Thread Starter gtaba

    (@gtaba)

    Hi,
    thanks for your quick reply.
    In the meantime, I’m trying to answer your questions:
    1) Yes all plugins are updated.
    2) I’ve got a http 500 error by checking with javascriptconsole after clicking “edit” for any of our products .
    3) The issue actually disappears when deactivating Yoast seo only. By deactivating other plugins, the issue still persists. I’ll try to do a deeper analyisis using the recommended health check plugin.
    4) I’ve got this error when activating debugging
    Warning: mysqli_real_connect(): Headers and client library minor version mismatch. Headers:50650 Library:50528 in /home/rq3spjqk/public_html/wp-includes/wp-db.php on line 1653

    Many thanks for your time.
    Best

    Hi @gtaba,

    Thanks for the information. We haven’t been able to reproduce the problem with editing products with Divi, Yoast SEO, and WooCommerce enabled.

    If you can send us the steps to help us reproduce the problem with a new or existing product, that would be very helpful.

    We have a few more questions below to see if we can get to the bottom of this:

    1. Are all your plugins and themes updated? If not, does updating solve the problem?

    2. Does your server meet the minimum requirements? You can find them here: Yoast Plugin Requirements

    3. We’d like to know what file or request is related to the 500 error. Can you send us a link to a screenshot that shows the JavaScript errors in the console?

    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Woocommerce Product conflict with Yoast’ is closed to new replies.