Support » Theme: OceanWP » Woocommerce Product Archive ‘Hover Style’ Image Gallery Behaviour

  • Resolved wonderlandfabrics

    (@wonderlandfabrics)


    Hi there. I recently changed the display mode of the products on my default shop page as well as the archive pages to OceanWP’s “Hover Style”. I’m loving the appearance and the pop-out tiles of the gallery when you hover over a product. But when I click on any of those product gallery image thumbnails, it opens the image in ‘fullscreen’ mode in the same window, but covering the webpage. I have to then click outside the image to close it and view the web page again. Is it possible to make it so that when I click the thumbnails it replaces the featured image on the product tile the same way that it does on the single product page?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter wonderlandfabrics

    (@wonderlandfabrics)

    Edit: I managed to get it working the way I want on the general shop page. However, I still have the problem on my custom archive pages. For context:

    https://wonderlandfabrics.co.za/shop – On this page The product gallery tiles behave exactly how I want them to.

    https://wonderlandfabrics.co.za/towels – On this page, clicking one of the product gallery tiles that come up on hover opens the image in full size, covering the page. The products here are displayed in an Elementor block with the shortcode: [products columns=”4″ category=”cat-towels” orderby=”id”]. It is done the same way on a handful of other pages.

    Now I need help to get the second page (…/towels) to behave the same way as the first (…/shop).

    Any help would be appreciated

    Hello,

    Please disable the elementor lightbox by following the steps and checkhttps://elementor.com/help/lightbox/.

    Thread Starter wonderlandfabrics

    (@wonderlandfabrics)

    Hi Abhiskek

    Thanks so much. I disabled the lightbox and now it works perfectly. Really appreciate it!

    You are most welcome and glad to hear that solution worked well.😊

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.