Support » Theme: evolve » Woocommerce problems with Evolve

  • Resolved NetMonkey

    (@headmonkey)


    I like Evolve as a pretty solid theme and I use it on two websites. But there’s some type of incompatibility going on with Woocommerce and the theme I believe.

    First I couldn’t get products to display as the default grid layout and I overcame that by finding some php for my functions file and css code.

    Now the last remaining obstacle to overcome is HUGE. Once you select a product on the shop page to buy, you’re transferred to the cart page, which is normal.

    But on the cart page, (there’s NO checkout button)! Without that, you can’t complete the transaction. I’ve tried disabling plugins, changing code in my functions file and nothing seems to work.

    This is a big deal that this weird theme behavior is happening. Please help.

    • This topic was modified 3 months, 3 weeks ago by  NetMonkey.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello,

    You have customize woo-commerce plugin so,i can’t help you.
    you customize theme so,woocommerce not display checkout option, in my theme we have see that option,please check below screenshot of our theme.

    http://prntscr.com/iwvegs

    Thank You

    I CAN’T BELIEVE THAT’S YOUR ANSWER! It’s called “troubleshooting”! When something doesn’t work with code incompatibilities, you try different solutions until the problem is fixed.

    You don’t tell people using your theme that you can’t help them! Are you saying your theme works correctly with Woocommerce? Because it’s not working in my install with your theme. But it does work with the twentyseventeen theme.

    What does that tell you? The problem is with YOUR THEME! It was doing this BEFORE I attempted anything to change any code!

    I was a network systems admin for 9 years. I would have NEVER told one of my customers that I couldn’t help them.

    Are you going to help me troubleshoot this problem? Or do I have to figure it out myself, then post back to this support forum how I fixed it, and show how I’m a better troubleshooter than you are?

    Someone from wordpress.org needs to get involved here please… I detest people that won’t do their jobs correctly, especially when others rely on them to!

    All right savanipriyank… Didn’t want to help me huh? (I) fixed the problem you couldn’t/wouldn’t help me with.

    For anyone else experiencing the problem of a missing — Proceed to Checkout button on their cart page in Woocommerce when using the Evolve theme, this is what fixed my problem. This php code should go into your cart.php file in your child theme:

    <div class="update action-group">
                <input type="submit" class="button" name="update_cart" value="<?php _e( 'Update Cart', '__x__' ); ?>" /> <input type="submit" class="checkout-button button alt wc-forward" name="proceed" value="<?php _e( 'Proceed to Checkout', '__x__' ); ?>" />
                <?php do_action( 'woocommerce_cart_actions' ); ?>
              </div>

    Then you need to style it with css. Choose your own colors:

    .wc-proceed-to-checkout a {
        background-color: #257DCC;
        padding: 10px 20px;
        font-family: 'Roboto Condensed',sans-serif;
        font-size: 16px;
        color: #fff;
        box-shadow: 0 5px 0 #000;
        border-radius: 5px;
        font-weight: 700;
        border: 0;
    }
    .wc-proceed-to-checkout a:hover {
        color: #fff;
        text-decoration: none;
    }

    Fixed savanipriyank! No thanks to you…

    • This reply was modified 3 months, 3 weeks ago by  NetMonkey.
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.