WordPress.org

Forums

WooCommerce - excelling eCommerce
Woocommerce - Price Disappears (4 posts)

  1. Devine_sir
    Member
    Posted 1 year ago #

    Hi - really hope someone can help.

    I have 250+products on my site. I've since decided I would change/replace some images. I have noticed I have been randomly losing the pricing on my products.

    I had prices in every product, update the image (not thinking to keep an eye on the price) and when I checked the product the price was gone!

    I'm loosing hours if not days trying to find the problem.

    Every time I update a product I save everything. Surely this is a bug?

    I was at one point opening 10+ products in separate tabs and saving the, I thought this may be the problem so I started to sue one window, save and continue. still I had the same problem

    I using

    WP 3.8.1
    Avada them (latest version)
    WC version: 2.0.20

    Can anyone help please?

    https://wordpress.org/plugins/woocommerce/

  2. Devine_sir
    Member
    Posted 1 year ago #

    I forgot to mention, im using localisation language for Czech. I have since changed back to English and have no problems.

    however, I need the site to be in Czech.

    The wp-config "language section was changed to cs_CZ" (or the czech code) and worked fine as a translator it just seemed to delete my prices

  3. andreiahs
    Member
    Posted 1 year ago #

    Hi Devine_sir
    I had a similar problem with my website, I have not changed anything since my last woocommerce update, so today I changed the price and then suddenly there was no price on the product. It drove me crazy, but I figured the solution of my problem, before I used to add the price like 1,99 (with a comma) but now we have to use 1.99 (with a dot). That was the problem for me.

  4. Devine_sir
    Member
    Posted 1 year ago #

    Hi,

    In Czech currency we don't use (.) or (,) this cannot be the problem - however thankyou for checking.

    If I bring up the products page, select a product with a price, open the product to edit the product - I have noticed (since posting originally) this is when the price disappears.

    I forgot to mention I have CodeStyling Localization installed (im sorry i forgot to add this).

    I deactivated the plugin, changed cs_CZ in wp-config to en_GB - I was then back to the original language English. I then logged out and back in. Reactivated the plugin, changed the wp-config back to English and saved it. I then opened up localisation, and selected Czech language under "woocommerce". I changed the translation that read "regular price" to the same "regular price" instead of the Czech translation. I also did this on the "sale" translation.

    I'm not saying this has worked - however it did seem to work or one hour last night. I will be updating this morning so I will certainly be posting the results.

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic