Support » Plugin: WooCommerce POS » Woocommerce POS giving php version message incorrectly

  • Resolved sophiavancouver

    (@sophiavancouver)


    The Woocommerce POS plugin is giving this error message upon activation:
    WooCommerce POS requires PHP 5.4 or higher. Read more information about how you can update »

    But the site is running PHP 5.4.43
    And when I activate the POS plugin and then the POS pro plugin, the pro plugin reports that the pro version requires the POS plugin be installed and activated (which it already is).

    I have tried all this again with a clean, freshly downloaded copy of the POS plugin.

    Please advise.

Viewing 1 replies (of 1 total)
  • Plugin Author kilbot

    (@kilbot)

    WooCommerce POS uses the phpversion() function to check your version of PHP, this should return the correct result unless your host has somehow blocked this function.

    Two things to check:

    1. Go to WP Admin > WooCommerce > System Status and check the PHP Version found by WooCommerce.

    2. Create a file called version.php and give it the contents <?php echo phpversion(); and upload it to your server. This should display the version of PHP you are running.

Viewing 1 replies (of 1 total)
  • The topic ‘Woocommerce POS giving php version message incorrectly’ is closed to new replies.