Support » Plugins and Hacks » [Resolved] WooCommerce – Plugin Error once activated

[Resolved] WooCommerce – Plugin Error once activated

  • Dear All,
    I hope one of you can help. I downloaded the latest plugin theme from WooThemes called Propulsion. I installed the theme and both its plugins correctly (bbPress & WooCommerce). I activated bbPress, and it seems to (see http://helpustrade.com/work fine. I activated WooCommerce and the message below appears at the top of my WordPress Dashboard page and also at the top of my web page (http://helpustrade.com/). Can someone please advise me on how to correct this (ps I have tried re-installing WooCommerce 3 times via WordPress and no improvement/joy). (Pps I am a wordpress novice – so any advice is god advice right now!).


    Warning: session_start() [function.session-start]: open(/var/chroot/home/content/93/8749193/tmp/sess_mm56kledungm47eci3natr84v6, O_RDWR) failed: No such file or directory (2) in /home/content/93/8749193/html/wp-content/plugins/woocommerce/woocommerce.php on line 13

    Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /home/content/93/8749193/html/wp-content/plugins/woocommerce/woocommerce.php:13) in /home/content/93/8749193/html/wp-content/plugins/woocommerce/woocommerce.php on line 13

Viewing 15 replies - 1 through 15 (of 16 total)
  • Your server needs its PHP SESSIONS configuring by your host – it seems the directory where sessions are stored may have incorrect permissions set.

    Hi gazzacliff,

    Sorry to hear you’re having trouble with your theme. While researching this for you, while Propulsion says it’s powered by WooCommerce, it is not from WooThemes. I would recommend trying a different theme or contacting the developer of Propulsion.

    I would also recommend switching to the default theme and disabling other plugins before installing WooCommerce. Once you have WooCommerce installed, you can then try switching themes and enabling plugins one by one to make sure everything is compatible.

    Hope this helps!

    Hi both, and thank you for the support!

    A bit of firefighting my end required I think. I have re-installed wordpress back to factory settings and the first thing i did was to install WooCommerce. Yet the same message appear – so I more than confident that it was not the theme so hopefully I have ruled out your comment ChristiNi (Thank you anyway). Mikejolley – I will take a look at the PHP sessions now – I am not 100% sure I understand what you are saying but I will try never the less. My HOST company is GODADDY.

    In addition to the error text above I am also getting the following messages:


    “The plugin generated 338 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin”.


    Warning: Unknown: open(/var/chroot/home/content/93/8749193/tmp/sess_mm56kledungm47eci3natr84v6, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0

    Again, any further insight to these problem would be welcome, thanks in advance,

    In addition:

    PHP – File Extensions:
    The domain supports the following file extensions:
    .php4 – PHP 4.x FastCGI
    .php – PHP 5.2.x FastCGI
    .php5 – PHP 5.2.x FastCGI

    As I am running a LINUX installation i have a php.ini installed as standard to my root directory, but I see no way of configuring it other than specifying the PHP tip (e.g. 4 or 5).

    GODADDY provides the following text with regard to PHP extension:
    “If you are running PHP 4, name your initialization file php.ini. (THIS IS WHAT I HAVE) If you are running PHP 5, name your initialization file php5.ini. Always upload the initialization file to the root directory of your site”.


    Hi gazzacliff,

    Can you check the file permissions on the tmp folder (/var/chroot/home/content/93/8749193/tmp)? Permissions should be set to 755.

    Hope this helps!

    HI ChristiNi,

    I cannot change the folder permission to a number. I can only set the read, write, and execute settings.
    This folder now has the following settings:
    rwx—rwx (707)


    Hi gazzacliff,

    Try changing that to:


    That will set the permissions to 755.

    Hope this helps!

    Hi ChristiNi,
    I am unable to change the middle three. I do not have this option.

    Hi ChristiNi,
    For info GODADDY solved the issue and you were spot on the /tmp folder needed updating! 🙂

    You’re welcome Gary! Glad I could help!

    Gazzacliff, what did you specifically ask godaddy to do? I just spoke with their customer service trying to get the same issue resolved and they said they couldn’t help me. Not sure but maybe I’ve lost something in translation.

    Hi, I asked them to update the:

    /tmp folder (within your wordpress folder)

    I got them to change some of the read/write settings to:

    rwxr-xr-x (755)


    rwx—rwx (707)

    That will set the permissions to 755.

    You cannot do this directly as it won’t let you. ChristiNi solved this problem, so I recommend reading the posts above.

    Tks 🙂

    Thanks. I fixed it in the meantime following the advice here: http://wordpress.org/support/topic/fast-secure-contact-form-3?replies=24

    (Frackin’ Godaddy!)

    I have the same issue BUT…

    My domain name is with GoDaddy, my HOST is UK2.

    I’m pretty sure that the wordpress directory / tmp is writable but I still get the problem. Could this be anything to do with GoDaddy?

    We are adding images to products as well as creating a copy of each product in the Portuguese language. For some reason, when we save/update the product, it is showing the price as FREE on the front end while it clearly has a price in the back-end. It is also deleting the categories that it resides in. Any help would be greatly appreciated.

    You can view it at thegreatamericancake.com/store

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] WooCommerce – Plugin Error once activated’ is closed to new replies.