Support » Plugin: WooCommerce » Woocommerce place order button not working because it does not load to be clicke

  • Resolved lgt1234

    (@lgt1234)


    Hi there,
    I have installed Woocommerce on my site. At first, my Woo store was functioning well but it’s now problematic.

    If I go to the shop and add a product to the cart, then, when I decide to make a payment, the Place Order button becomes unclickable. It looks like there is a never ending process on the page.

    So to resolve that, I tried disabling all plugins and leaving woocommerce only. Yet, the problem was not solved.

    Finally, I deleted the entire WP script, the WP content folder at the domain folder, and the associated database.

    Unfortunately, after installing a new WP and woocommerce, the problem is the same.

    Please visit my store (link below) to checkout to see what this problem is.

    I will greatly appreciate your quick support.

    Regards

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter lgt1234

    (@lgt1234)

    I have also realized that the Add to cart buttons on the shop are also having the same problem.

    When clicked, it begins a never-ending process. So I installed WP Multi-Step Checkout plugin to see if the problem will be resolved, unfortunately, the continuous loading process is the same.

    Plugin Support Stuart Duff – a11n

    (@stuartduff)

    Automattic Happiness Engineer

    Hi @lgt1234,

    Looking at your site today it seems you have some kind of Ajax loading error which is preventing the Ajax button functionality from working correctly.

    When trying to add a product to cart from the ship page the Ajax dynamic loading stalls and you see a continuous loading circle. If using the Add To Cart button on a single product page however which does not use Ajax the product is successfully added to cart.

    You can deactivate Ajax product add to cart by visiting **WooCommerce > Settings > Products** and deactivating this setting.

    Image Link: https://cloudup.com/c1LbwUvTCtZ

    If the products on the shop page then add to cart you’ll know for sure something on your particular WordPress installation is preventing the Ajax features from working as intended.

    Should that be the case you can test on your site by disabling all other plugins aside from WooCommerce along with switching to a theme like Storefront. This will help with trying to and locate what software you have installed which could possibly be causing this behaviour? You could use a free plugin called Health Check and Troubleshooting to carry out such testing.

    Once you have disabled all other plugins and switched theme if the behaviour is resolved you can then enabled your theme and sites plugins testing after each one is enabled until the behaviour returns to locate the culprit.

    https://docs.woocommerce.com/document/how-to-test-for-conflicts/

    Thread Starter lgt1234

    (@lgt1234)

    Hi @stuartduff,
    After deactivating Ajax, the ‘Add to cart’ button at the shop page works fine but the story is still the at checkout.

    Thread Starter lgt1234

    (@lgt1234)

    Hi @stuartduff,
    I found something strange on my site.

    In my first WP installation, I installed a plugin called woocommerce cart abandonment recovery that did not work fine so I deleted it.

    Then, I later realized that my woo checkout was malfunctioning. In an effort to solve the problem, I deleted my entire WP site plus database and all plugins from my domain.

    Again, I went ahead to install a fresh WP with new auto generated database. Yet, the problem existed. I did the deletion again and the issue was still the same.

    To be sure of what was actually going on, I decided to create a test subdomain at test.legitebusiness(dot)com and installed woocommerce and everything worked perfect.

    Back to my main domain at legitebusiness(dot)com where I did a fresh WordPress installation. I did not install any of my old plugins, yet the fresh WooCommerce checkout button is still not loading.

    Now, I found out a strange thing on the main domain WP site.
    I wanted to install a new plugin to see if the problem will be resolved. And I came across this plugin (woocommerce cart abandonment recovery) which is indicated as Active.
    [URL=https://www.file-upload.com/71jdoqbfwr5z]IMG_20201017_184421.png – 104 KB[/URL]
    https://www.file-upload.com/71jdoqbfwr5z

    Meanwhile, I did NOT install that in the new WP. Though I installed it on the old and deleted site.

    Checking back at the plugins dashboard, it is still not installed. So how come I am still seeing it as activated in the plugin search area but can’t find it among my installed plugins?

    I am sure that this will be the cause of this malfunctioning of my woocommerce checkout button.

    Please how do I delete this activated but unseen plugin?

    Plugin Support Stuart Duff – a11n

    (@stuartduff)

    Automattic Happiness Engineer

    Hey @lgt1234,

    If you login to your sites hosting control panel and navigate to the folder WordPress folder of /wp-content/plugins/ you will be able to see all of the folders for plugins you have installed on your WordPress installation.

    If you see a folder relating to the abandoned cart plugin within /wp-content/plugins/ which you installed previously you can delete that plugins folder from there.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Woocommerce place order button not working because it does not load to be clicke’ is closed to new replies.