Support » Plugin: WooCommerce » WooCommerce + php 8.1 + WordPress 5.7.2

  • Resolved kaznim

    (@kaznim)


    I have an issue with using new PHP 8.1 on WordPress 5.7.2. Everything work just fine, until turn on WooCommerce 5.3.0. Then whole site fall down.

    Here is error message what I’m getting:

    Fatal error: Uncaught Error: Call to undefined function putenv() in /data/web/virtuals/2036/virtual/www/domains/e-biowa.cz/wp-content/plugins/woocommerce/includes/class-wc-regenerate-images-request.php:37 Stack trace: #0 /data/web/virtuals/2036/virtual/www/domains/e-biowa.cz/wp-content/plugins/woocommerce/includes/class-wc-regenerate-images.php(49): WC_Regenerate_Images_Request->__construct() #1 /data/web/virtuals/2036/virtual/www/domains/e-biowa.cz/wp-includes/class-wp-hook.php(292): WC_Regenerate_Images::init('') #2 /data/web/virtuals/2036/virtual/www/domains/e-biowa.cz/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters(NULL, Array) #3 /data/web/virtuals/2036/virtual/www/domains/e-biowa.cz/wp-includes/plugin.php(484): WP_Hook->do_action(Array) #4 /data/web/virtuals/2036/virtual/www/domains/e-biowa.cz/wp-settings.php(560): do_action('init') #5 /data/web/virtuals/2036/virtual/www/domains/e-biowa.cz/wp-config.php(90): require_once('/data/web/virtu...') #6 /data/web/virtuals/2036/virtual/www/domains/e-biowa.cz/wp-load.php(37): require_once('/data/web/virtu...') #7 /data/web/virtuals/2036/virtual/www/domains/e-biowa.cz/wp-admin/admin.php(34): require_once('/data/web/virtu...') #8 /data/web/virtuals/2036/virtual/www/domains/e-biowa.cz/wp-admin/plugins.php(10): require_once('/data/web/virtu...') #9 {main} thrown in /data/web/virtuals/2036/virtual/www/domains/e-biowa.cz/wp-content/plugins/woocommerce/includes/class-wc-regenerate-images-request.php on line 37

    Please does anyone know, if there is any problem with compatibility? I didn’t find any information about it.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Mirko P.

    (@rainfallnixfig)

    Hi @kaznim,

    I have an issue with using new PHP 8.1 on WordPress 5.7.2. Everything work just fine, until turn on WooCommerce 5.3.0. Then whole site fall down.

    Upon checking the latest PHP releases I see it reached the version 8.0.7 with 8.0.6 being the stable release.

    So I’m not really sure which version you’re using that caused that fatal error. Can you switch to the stable version and let us know if you still get the error? In that case, please share a copy of your System Status report as found under WooCommerce > Status > System status? Select “Get system report” and then “Copy for support”. Once you’ve done that, paste it here in your response.

    Thanks!

    Thread Starter kaznim

    (@kaznim)

    Hi @rainfallnixfig,

    I didn’t know, stable version is 8.0.6.. Sadly my provider have only 8.0.1 for now.. So i gues i have to wait, utly they will upgrade to new version. I will try it to another hosting and i will see..

    Plugin Support Mirko P.

    (@rainfallnixfig)

    Hi @kaznim,

    Since the PHP version is set at the server-level by your hosting company you may find and try lower versions to ensure full compatibility.

    WordPress itself being able to run on PHP 8 does not indicate “full” compatibility. The process to achieve that state takes a larger amount of time within the greater ecosystem including plugins and themes.

    I’m now marking this thread as resolved. If you have further questions, please feel free to open a new topic.

    Cheers!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WooCommerce + php 8.1 + WordPress 5.7.2’ is closed to new replies.