Support » Plugin: Currency Switcher for WooCommerce » Woocommerce Orders page doesn’t follow number of decimals set in the plugin.

  • Hello.
    It seems to me that there is a conflict between the setting of number of decimals in the plugin and in Woocommerce global settings. In Woocommerce I have 2 decimals set. Then in the plugin, where I have 2 additional currencies set(so I use 3 currencies total – EUR, USD, CZK), I have 2 decimals set with EUR, USD and 0 decimals with CZK. The prices in CZK are shown correctly with none decimals on frontend, in invoices, in emails… However, when I go into Woocommerce Orders page, the prices in CZK follow Woocommerce default settings – two decimal number.
    Thank you.

    https://liberlapidum.com/wp-content/uploads/2018/10/bug.png

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello.
    I now noticed that the number formats set in your plugin don’t affect number format displayed in Wocommerce orders at all. (tested on new clean WordPress install)
    When I open any order, prices there are always shown according to default Woocommerce price format. They are also like that in emails and invoices.
    Only first email and Invoice which are sent after passing checkout on frontend is correct.
    Can you please check that?

    Hi,

    You mean the order page on admin?
    I can try to filter the totals at least. But I don’t think we can change the order item value, because it’s the original value and afterall it will be converted on frontend too.

    Or is it other issue you are referring to?

    Hello.
    Yes, I mean admin order page. For example, let’s say I use CZK currency and in your plugin, I set custom price format like – none decimals, different thousand separator and symbol position. So, on the frontend, all prices look like 2 125 Kč, 1 132 Kč etc.
    However, when I make a purchase, go to Admin orders, the prices are shown according to the default woocommerce format. Like Kč2,125.35 Kč1,132.57 etc.
    Also when I change order status to completed, a customer gets an confirmation email with prices looking like that. It’s quite useless because the prices look differently than on the frontend.

    I tried to switch to the plugin by realmagg and this problem doesn’t appear.

    Hi, I think I got it.
    I ended up creating a new option on general section called:

    Format price – Format price Format prices on admin order edit page

    Please give it a try

    Hi.
    How can I try it? 🙂

    Hi,

    It’s located on plugin’s settings page at:
    WooCommerce > Settings > Currency Switcher > General > Order Options

    It looks great.
    Thanks! You helped me again.
    I am going to test this further if there is any problem, but it seems working correctly.
    However, if you had free time, you could also reflect the currency format on the admin Summary Orders page 🙂
    https://liberlapidum.com/wp-content/uploads/2018/10/fix.png

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Woocommerce Orders page doesn’t follow number of decimals set in the plugin.’ is closed to new replies.